Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - TOTVS BackOffice (Línea Protheus) - MI - Gestión de Servicios (SIGATEC) - TECXFUN - expected string expression in FieldPut AB7_XTEND in file (ruta) dbenv.cpp at line 819 on AT450GRAVA(TECXFUN.PRW) 04/01/2019 17:09:14 line : 1214


time.png Tiempo aproximado para lectura: 00:10:00 min

Ocurrencia
En el módulo de Gestión de Servicios (SIGATEC) al ingresar a la rutina Orden de Servicios (TECA450) se presenta un error.log:


expected string expression in FieldPut AB7_XTEND in file (ruta) dbenv.cpp at line 819 on AT450GRAVA(TECXFUN.PRW) 04/01/2019 17:09:14 line : 1214

mceclip0.png


Ambiente
Cross Segmentos - TOTVS BackOffice (Línea Protheus) - MI - Gestión de Servicios (SIGATEC) - Versión 12


Causa
Este incidente puede ocurrir por campos de usuario que tienen inconsistencias o son utilizados en alguna función de usuario y/o Punto de Entrada.



Solución

Para solucionar esta ocurrencia, realice los siguientes pasos:

1. Este error.log hace referencia específicamente al uso del campo AB7_XTEND, el cual es un campo de usuario, por lo cual es necesario que pueda revisar las propiedades de este campo y que exista físicamente en su tabla AB7 de Topconnect;

  • Nota: Por estándar del diccionario de datos el campo AB7_EXTEND no es creado, por este motivo se considera como un campo de usuario




2. Garantice tener la rutina TECXFUN con fecha igual o superior a 04/11/2021; Caso contrario solicitar la actualización a Soporte Protheus Mercado Internacional vía ticket (DSERSGS-13361 );


3. Se sugiere que garantice descargar la ultima actualización de librerías disponible en el portal del Cliente, para aplicar en su ambiente de pruebas, en caso de tener rutinas de librerías desactualizadas:



4. Se sugiere realice la validación del escenario deshabilitado sus customizaciones (Función de usuario y/o puntos de entrada), se anexa el link del siguiente articulo donde se indica como hacer esta desactivación:

 


4. Valide el ingreso a la rutina Orden de Servicios (TECA450) sin que sea presentado el error.log.

mceclip1.png



Conozca más:
Para consultar la información contenida en nuestro banco de conocimientos, acceda a los siguientes enlaces: Help On-Line - Orden de Servicio (TECA450)

¿Fue útil este artículo?
Usuarios a los que les pareció útil: 0 de 0

0 Comentarios

Inicie sesión para dejar un comentario.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Rellene los campos siguientes para iniciar el chat:

Chat _