FAQs - Suporte técnico

Cross Segmentos - TOTVS BackOffice (Línea Protheus) - MI - Compras (SIGACOM) - expected string expression in FieldPut C7_DATPRF on A120GRAVA(MATA120.PRX)


time.png Tiempo aproximado para lectura: 2:00 min

Ocurrencia
En módulo Compras, al intentar incluir un pedido de compra en la rutina MATA121 se genera el error: expected string expression in FieldPut C7_DATPRF in file C:\bamboo\xml-data\build-dir\TP11-OF20300-TECXWIN64\advpl\dbenv.cpp at line 816 on A120GRAVA(MATA120.PRX)

erro.jpg


Ambiente
Cross Segmentos - TOTVS BackOffice (Línea Protheus) - MI - Compras (SIGACOM) - Versión 12

Causa
Este incidente ocurre debido a que el campo C7_DATPRF tiene una definición incorrecta en la estructura de la tabla SC7 en la base de datos.

Solución
Para solucionar esta ocurrencia, realice los siguientes pasos:
1. Haga un respaldo de su tabla SX3 y SC7 del ambiente donde replica el error;
2. Mediante APSDU haga un Drop de la tabla SC7;
3. Ingrese al Configurador y confirme que el campo C7_DATPRF está definido como tipo fecha;

CAMPO.jpg

4. Ingrese a la rutina MATA121 Pedido de Compra y haga clic en el botón Incluir para regenerar tabla SC7;
5. En APSDU restaure los datos respaldados en el paso 1 de la tabla SC7;
6. Ingrese nuevamente a la inclusión de Pedido de Compra y confirme que el error no es mostrado.

¿Fue útil este artículo?
Usuarios a los que les pareció útil: 0 de 0

0 Comentarios

Inicie sesión para dejar un comentario.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Rellene los campos siguientes para iniciar el chat:

Chat _