Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

TOTVS RH - TOTVS RH (LINEA PROTHEUS) - MI – Gestión de Personal (SIGAGPE) – GPER884 – Al generar el timbrado, el sistema genera el mensaje "El TipoDeComprobante NO es I,E o N, y un concepto incluye el campo descuento." No genera el timbre fiscal

time.png Tiempo aproximado para lectura: 00:03:00 min

Ocurrencia

En modulo Gestión de Personal, al generar el timbrado, el sistema genera el mensaje "El TipoDeComprobante NO es I,E o N, y un concepto incluye el campo descuento." no genera el timbre fiscal

 

Ambiente

TOTVS RH - TOTVS RH (LINEA PROTHEUS) - MI – Gestión de Personal (SIGAGPE) – Reléase 12

 

Causa

Este incidente se origina debido a que el campo descuento al tener un valor igual a cero no se debe imprimir en el archivo XML

TOTAL_DEDUCCION_TOTAL_DESCUENTO.jpg

Solución

Dar tratamiento en los atributos <TotalDeducciones> y <TotalDescuento> para poder realizar el timbrado del recibo

 

Importante: Si en su ambiente ya existe el script GPER884.INI con personalizaciones, es recomendable evitar su actualización, en cambio, deberá editarlo y realizar las modificaciones mencionadas en las secciones indicadas en este artículo.

 

1.- Ingrese al archivo GPER884.ini para agregar el siguiente tratamiento, observe el ejemplo de sintaxis;

Cadena original

//CADENA  ORIGINAL                              
[SRA CADENAORIGINAL_SELLO]
(PRE) _aTotal[001] += IIf(nOtroDedu+nImpReten <> 0, ' Descuento="' + Alltrim(Transform(Round(nOtroDedu+nImpReten,2), "99999999.99")) + '"', "")

//COMPLEMENTO: NOMINA:NOMINA
[XXX NOMINA]
(PRE) _aTotal[001] += IIf(nTotDGrav+nTotDExen <> 0, ' TotalDeducciones="' + Alltrim(Transform(Round(nTotDGrav+nTotDExen,2), "99999999.99")) + '"', "")

//COMPLEMENTO: NOMINA:DEDUCCIONES
(PRE) _aTotal[002] += IIf(nOtroDedu <> 0, ' TotalOtrasDeducciones="' + Alltrim(Transform(Round(nOtroDedu,2), "99999999.99")) + '"', "")

[XXX CONCEPTO]

(PREREG) IIf(nTotDGrav+nTotDExen <> 0, (_aTotal[002] +=' Descuento="' + Alltrim(Transform(Round(nTotDGrav+nTotDExen,2), "99999999.99")) + '"',.T.), "")

Configuración en los Nodos

//Descuento
 (PRE) cCadOrig += IIf(nOtroDedu+nImpReten <> 0, Alltrim(Transform(Round(nOtroDedu+nImpReten,2), "99999999.99")) + _aTotal[098], "")

//TotalDeducciones
(PRE) cCadOrig += IIf(nTotDGrav+nTotDExen <> 0, Alltrim(Transform(Round(nTotDGrav+nTotDExen,2), "99999999.99")) + _aTotal[098], "")

//TotalDeducciones
(PRE) cCadOrig += IIf(nTotDGrav+nTotDExen <> 0, Alltrim(Transform(Round(nTotDGrav+nTotDExen,2), "99999999.99")) + _aTotal[098], "")

 

2.- Una vez configurado el tratamiento para los atributos <TotalDeducciones> y <TotalDescuento>   ingrese a (Informes|Periódicos|Recibo CFDi) seleccionar los parámetros correspondientes para generar el archivo XML y obtener el timbre fiscal.

¿Fue útil este artículo?
Usuarios a los que les pareció útil: 0 de 0

0 Comentarios

Inicie sesión para dejar un comentario.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Rellene los campos siguientes para iniciar el chat:

Chat _