Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

TOTVS RH - TOTVS RH (LINEA PROTHEUS) - MI – Gestión de Personal (SIGAGPE) – GPER884 – El nombre del cliente contiene el carácter "&" al generar el XML no se puede visualizar y no genera el informe en formato PDF

time.png Tiempo aproximado para lectura: 00:03:00 min

Ocurrencia

En módulo Gestión de Personal, al ejecutar el recibo CFDI El nombre del cliente contiene el carácter "&" y al momento de armar la cadena original no está considerando la conversión por lo cual no está armando el XML y no permite generar el recibo en formato PDF

 

Ambiente

TOTVS RH - TOTVS RH (LINEA PROTHEUS) - MI – Gestión de Personal (SIGAGPE) – Reléase 12

 

Causa

Este incidente se origina debido a que el contenido de la Cadena Original en adenda del archivo XML se encuentra un carácter especial “&” en el nombre de la sucursal sin tratamiento

 

Solución

Utilizar la función de caracteres especiales CFDCarEsp() para convertir el “&”  a “&” y pueda realizar el timbrado y generación del recibo en formato PDF

 

Consideraciones Importantes en el archivo XML:

  • Al dar tratamiento en la sección “cadena original en adenda” al abrir el archivo en explorador (internet) se puede visualizar el símbolo “&”;
  • Sin embargo cuando el archivo es abierto en un editor de texto podrá visualizar el tratamiento que se da con la función CFDCarEsp() ya que agrega al símbolo &
  • El tratamiento "&" para símbolos especiales como lo es “&” es aceptado por los PAC en la ejecución del timbrado del recibo de nómina CFDI.

1.- Ingrese al archivo GPER884.ini para agregar la validación de caracteres especiales CFDCarEsp() en la Línea 60 (Cadena original en adenda), observe la imagen y ejemplo de sintaxis;

(PRE) cCadOrig += CFDCarEsp(Alltrim(SRA->RA_NOME)) + _aTotal[098]

cfdCaresp.jpg

2.- Una vez configurada la función de caracteres especiales CFDCarEsp() en el nombre del emisor ingrese a (Informes|Periódicos|Recibo CFDi) seleccionar los parámetros correspondientes para generar el archivo XML y visualizar el recibo en formato PDF.

¿Fue útil este artículo?
Usuarios a los que les pareció útil: 0 de 0

0 Comentarios

Inicie sesión para dejar un comentario.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Rellene los campos siguientes para iniciar el chat:

Chat _