Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - TOTVS BackOffice (Línea Protheus) - MI - Facturación (SIGAFAT) - MATR600 - Error -19 - Invalid Field Order in Query -- Memo fields must be grouped at the end of the Query on __EXECSQL(APLIB300.PRW)



time.png Tiempo aproximado para lectura: 00:10:00 min

Ocurrencia
En el módulo de Facturación (SIGAFAT), al ejecutar el informe Pedido de venta vs. Clientes (MATR600) se genera un error.log:


  • TOP Error -19 - Invalid Field Order in Query -- Memo fields must be grouped at the end of the Query. ( From tODBCStatement::BindCols )
    Thread ID [5588] User [Administrador] IO [9171] Tables [32] MaxTables [32] Comment [MATR600 (Fecha: 30/01/2020 08:37:36)- TCPIP - ThreadID(4896)] SP [ ] Traced [No] SQLReplay [No] InTran [No] DBEnv [MSSQL/TOTVS12] DBThread [(SPID 52,53)] Started [25/09/2021 12:50:42] IP [10.0.0.4:4343] IDLE [ ] InTransact [ ] Memory [695216] Running [ROP_QUERY] RCV [116829] SND [862398] TCBuild [20180606-20180904] TCVersion [18.1.1.3] ARCH [64] OS [WINDOWS] BUILD [RELEASE]
    on __EXECSQL(APLIB300.PRW) 30/08/2021 18:16:27 line : 149



Ambiente
Cross Segmentos - TOTVS BackOffice (Línea Protheus) - MI - Facturación (SIGAFAT) - Versión 12


Causa
El error puede ocurrir al activar la opción de impresión de registros donde, se puede estar considerando algún campo de tipo MEMO, el cual puede estar generando el Error.log y/o por desactualización del componentes del DBAccess.


Solución
Para solucionar esta ocurrencia, realice los siguientes pasos:


1. Garantice tener aplicada la ultima actualización de librerías disponibles en el Portal del Cliente en su ambiente de pruebas inicialmente; Se anexa el link de descarga de la actualización disponible al día de hoy 25/09/2021 para reléase 12123 o superior;

 




2. Realice la descarga y actualización del DBAccess, debe direccionar su ambiente de pruebas a este nuevo DBAccess para realizar la validación del escenario reportado;


mceclip0.png



3. Reinicie los servicios de Protheus;


4. Garantice estar ejecutando el informe estándar MATR600 y no un informe customizado especifico de cliente, para ello revise las propiedades de la opción del menú en la rutina de menús desde el configurador;

mceclip1.png



5. Una vez garantizado los puntos anteriores, valide la generación del informe MATR600.

mceclip2.png


mceclip4.png

mceclip5.png





Conozca más:
Para consultar la información contenida en nuestro banco de conocimientos, acceda a los siguientes enlaces:

Help On-Line - Pedido de venta vs. Clientes (MATR600)

¿Fue útil este artículo?
Usuarios a los que les pareció útil: 0 de 0

0 Comentarios

Inicie sesión para dejar un comentario.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Rellene los campos siguientes para iniciar el chat:

Chat _