Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

FRAMEWORK - Framework (Línea Protheus) - MI - Opción no disponible en Protheus Function called by FWSQLSTRUCT

time.png Tiempo aproximado para lectura: 5 min

Ocurrencia
Al ingresar al sistema Protheus, en cualquier rutina y de forma aleatoria se presenta el siguiente mensaje de error, seguido el error log: "TC_Struct NOT FOUND - Check DBAPI and DBAccess version on FWSQLSTRUCT(FWSQLSTRUCT.PRW)"
mceclip0.png


Ambiente
FRAMEWORK - Framework (Línea Protheus) - MI - 12

Causa

El mensaje de error "TC_Struct NOT FOUND - Check DBAPI and DBAccess version on FWSQLSTRUCT(FWSQLSTRUCT.PRW) " indica una incompatibilidad de versión del BAccess y de la DBApi con el reléase 12.1.27 en uso

Solución
Para solucionar esa ocurrencia, realice los siguientes pasos:
-Actualice todos los AppServer de su ambiente (master y slaves) con la última versión disponible en el portal;
-Actualice el DBAccess de su ambiente (Master y Slaves) con la última versión disponible en el portal;
-Limpie y elimine todos los logs (console.log, error.log Dbaccess.log e Dbconsole.log) de todos;
-Realice el procedimiento de actualización de la DBApi, en todos los Appserver de su ambiente que se conectan con el DBAccess;
-Reinicie los servicios y verifique.

¿Fue útil este artículo?
Usuarios a los que les pareció útil: 0 de 0

0 Comentarios

Inicie sesión para dejar un comentario.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Rellene los campos siguientes para iniciar el chat:

Chat _