Tiempo aproximado para lectura: 00:01:00 min
Ocurrencia
En catálogos de sistema Protheus, al intentar modificar o visualizar un registro se detona error.log:
El campoXX_XXXXXXX vincule a la carpeta:X, pero no existe. on FWFORMFIELD:PREPAREFIELDS(FWFORMFIELD.PRW)

Ambiente
Cross Segmentos - TOTVS BackOffice (Línea Protheus) MI - Facturación (SIGAFAT) - Versión 12
Causa
Este incidente se presenta por inconsistencias a nivel base de datos, normalmente cuando se realiza alguna alteración de tabla, para cambiar el orden de carpetas y un campo no se encuentra físicamente en las tabla.
Solución
Para solucionar esta incidencia realice los siguientes pasos.
1. Realice un respaldo de la base de datos del ambiente.
2. Ingrese al módulo Configurador y localice el campo al cual hace referencia el error, en el apartado de Diccionario de Datos, tanto en la opción "Campos" como en la opción "Carpetas".

En el caso de ejemplo, el error hace referencia al campo A1_ENTID localizado en la carpeta 5
3. Verifique que el campo a nivel base de datos exista en la tabla física, en el caso del ejemplo la tabla es la SA1.
4. Realice los ajustes correspondientes, en caso de que el campo esté vinculado en la carpeta a la cual hace referencia el error y no se encuentre en la tabla, realice las correcciones.
0 Comentarios