Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

TOTVS RH - TOTVS RH (LINEA PROTHEUS) - MI – Gestión de Personal (SIGAGPE) – GPEA240 – Al capturar ausencias, se muestra array out of bounds ( 1 of 0 ) on GP240VALIDNUMPAG(GPEA240.PRX)

time.png Tiempo aproximado para lectura: 00:05:00 min

 

Ocurrencia
Al registrar un ausentismo, el sistema genera el error "array out of bounds ( 1 of 0 ) on GP240VALIDNUMPAG(GPEA240.PRX)" y termina la ejecución


Ambiente

TOTVS RH - TOTVS RH (LINEA PROTHEUS) - MI – Gestión de Personal (SIGAGPE) – Reléase 12


Causa

Este error se presenta porque las tablas SRM y SRY están relacionadas en cuanto a los códigos relacionados con cada script.


Solución
Para solucionar esta ocurrencia, realice los siguientes pasos:

  1. Para solucionar este incidente, es necesario realizar el procedimiento de cambio de nombre de las tablas SRM y SRY, como se muestra a continuación:
  • Ingrese al Configurador (SIGACFG) en Base de datos | Diccionarios | Base de datos. Seleccione el Diccionario de datos en la esquina superior izquierda y luego seleccione el icono con el símbolo de la lupa:

1.jpg

  • Se mostrará la siguiente pantalla. En el campo de búsqueda, escriba SRY y haga clic en Buscar. Luego seleccione el ícono Editar;

2.jpg

  • En el siguiente ejemplo, la tabla SRY tiene el nombre SRYT10, cámbielo por un nombre que no exista en su entorno, SRYT10_T por ejemplo;

3.jpg

  • Después del cambio, el campo Nombre se cambiará a SRYT10_T. Haga clic en Confirmar;

4.jpg

  • Explorar se mostrará de nuevo. Haga clic en el icono del disquete. Se abrirá una nueva ventana, haga clic en Siguiente en todas las ventanas que se muestran; Esta acción depende del acceso exclusivo:

5.jpg

  • La ventana de abajo se mostrará al final del procesamiento. Compruebe si se muestra el mensaje: Actualización completada correctamente y Finalizar;

6.jpg

  1. Ingrese al módulo SIGAGPE, al menú | Definición de cálculo | Tipos de procedimiento para que las tablas se vuelvan a crear y cargar según los scripts estándar;

  2. Realice el proceso para incluir las ausencias y confirme si todavía se muestra el error.
¿Fue útil este artículo?
Usuarios a los que les pareció útil: 0 de 0

0 Comentarios

Inicie sesión para dejar un comentario.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Rellene los campos siguientes para iniciar el chat:

Chat _