Ocurrencia
En módulo Contabilidad al intentar realizar el cálculo de Resultado a través de la rutina CTBA211 se detona mensaje de Incompatibilidad que impide continuar el proceso "La rutina CTBA211 esta desactualizada."
Ambiente
Cross Segmentos - TOTVS BackOffice (Línea Protheus) MI - Contabilidad de Gestión (SIGACTB) - Todas las versiones
Causa
Este incidente se presenta debido a una incompatibilidad entre el archivo instalado en el Stored Procedure (archivo .sps) y la rutina involucrada. En este caso la rutina CTBA211 tiene código de proceso mas antiguo y el archivo de .sps se encuentra más actualizado.
Solución
Para solucionar esta ocurrencia, realice los siguientes pasos:
1.- Garantice tener la última versión de los archivos de Stored p12_01.sps, p12_02.sps, p12_03.sps disponible, los cuales puede solicitar por medio de ticket a Soporte Técnico Mercado Internacional.
2.- Coloque los archivos .sps en la carpeta system
3.- Confirme tener la rutina CTBA211 con fecha igual a 30/03/2021, de lo contrario solicite a Soporte Técnico Mercado Internacional, por medio de ticket el PATCH de actualización. PATCH puntual (ISSUE DSERCTR1-31385)
4.- Si tiene instalados los Stored Procedure, previamente, deberá desinstalarlos desde el modulo del configurador, caso contrario, omitir este paso.
5.- Aplique el PATCH correspondiente a la actualización de la rutina CTBA211
6.- Ejecute la instalación del Stored Procedure a través del módulo Configurador en rutina CFGX051-Stored Procedure, deberá seleccionar el proceso 01 y 03 para la empresa en la cual desea instalarlo.

7. Ejecute la rutina de Cálculo de resultados (CTBA211) y confirme resultados.
0 Comentarios