Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

TOTVS RH - TOTVS RH (Línea Protheus) - MI - Gestión de Personal (SIGAGPE) - invalid macro source (SSYacc0105e: Error token failed, no valid token)

Ocurrencia
En el módulo gestión de personal, al ingresar a la rutina Ausencias -GPEA240 es generado el siguiente error log: invalid macro source (SSYacc0105e: Error token failed, no valid token):({|a,b,c| FWInitCpo(a,b,c),xRet:=(EJEMPLO DE SINTAXIS: GP240RETCONT("RCH",4,XFILIAL("RCH")+CPROCESSO,"RCH_PER","EMPTY(RCH->RCH_DTFECH) .AND. (RCH->RCH_PROCES == C),FWCloseCpo(a,b,c,.T.),FwSetVarMem(a,b,xRet),xRet }) on FWBUILDFEATURE(PROTHEUSFUNCTIONMVC.PRX) 17/02/2021 17:06:13 line : 5467

Ambiente
TOTVS RH - TOTVS RH (Línea Protheus) - MI - Gestión de Personal (SIGAGPE) - 12.1.27

Causa
Ese incidente ocurre por inconsistencia en la configuración del Inicializador estándar (X3_RALACAO), en algún campo del diccionario de datos


Solución
Para solucionar esa ocurrencia, realice los siguientes pasos:
1. En el error log, identifique el campo inconsistente con la sintaxis invalida que menciona el error. Para este ejemplo es el campo R8_PER
1.png

2. Realice el ajuste pertinente en el inicializador. Por ejemplo:
Ejemplo de sintaxis: P240RETCONT("RCH",4,XFILIAL("RCH")+CPROCESSO,"RCH_PER","EMPTY(RCH->RCH_DTFECH) .AND. (RCH->RCH_PROCES == C

Lo correcto sería:
gp240RetCont("RCH",1,xFilial("RCH")+cProcesso,"RCH_PER","Empty(RCH->RCH_DTFECH) .AND. (RCH->RCH_PROCES == cProcesso)")

3. Guarde los cambios y verifique que el error log ya no sea presentado.

 

¿Fue útil este artículo?
Usuarios a los que les pareció útil: 0 de 0

0 Comentarios

Inicie sesión para dejar un comentario.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Rellene los campos siguientes para iniciar el chat:

Chat _