Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - TOTVS Backoffice (Linea Protheus) - MI - Facturación (SIGAFAT) - Transmisión directa a SUNAT presenta error WSCERR048 / SOAP FAULT Receiver cuando TSS utiliza PostgreSQL

relogio_tempo_leitura_2.png Tiempo aproximado de lectura 00:05:00 min 

Ocurrencia
En el módulo Facturación, al intentar realizar la transmisión de una Factura con el metodo de transmisión directa a SUNAT, se presenta el error "WSCERR048 / SOAP FAULT Receiver". Este problema ocurre específicamente cuando la base de datos del TSS es PostgreSQL. El análisis del log del TSS revela el error subyacente: 'ERROR: operator does not exist: character = integer', lo que indica una incompatibilidad de tipos de datos en una consulta SQL, ya que se intenta comparar un campo de tipo carácter con un valor numérico.

Entorno
Cross Segmentos - TOTVS Backoffice (Linea Protheus) - MI - Facturación (SIGAFAT) - A partir de la versión 12.1.2410

Causa 
Este incidente ocurre, por el error subyacente: 'ERROR: operator does not exist: character = integer', lo que indica una incompatibilidad de tipos de datos en una consulta SQL, ya que se intenta comparar un campo de tipo carácter con un valor numérico.

Solución
Para solucionar esta ocurrencia, es necesario actualizar la rutina TSSINTEGSUNAT.PRW del TSS a una fecha igual o superior al 01/07/2026, ya que en esa rutina se ajustó la consulta SQL ejecutada durante la transmisión para que sea compatible con la base de datos PostgreSQL. La corrección asegura que el tipo de dato del campo "ID_ENT" sea tratado correctamente como carácter, evitando el conflicto de tipos que impedía la comunicación con la SUNAT.

 

Esta ifnormación fue tomada del documento tecnico: https://tdn.totvs.com/pages/releaseview.action?pageId=1085095739

¿Fue útil este artículo?
Usuarios a los que les pareció útil: 0 de 0

0 Comentarios

Inicie sesión para dejar un comentario.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Rellene los campos siguientes para iniciar el chat:

Chat _