Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - TOTVS BackOffice (Línea Protheus) - MI - Financiero (SIGAFIN) - Error "Internal Server Error" al registrar pagos en moneda extranjera tras modificar la tasa de cambio FINA998


relogio_tempo_leitura_2.png Tiempo aproximado de lectura 01:00 min 


Ocurrencia
Se identificó una incidencia al registrar un pago asociado a una factura en moneda extranjera (dólares).

El comportamiento ocurre cuando:

  • Se selecciona una factura en dólares.
  • Se modifica la tasa de cambio durante el proceso de pago.
  • Posteriormente se intenta registrar la forma de pago o las retenciones.

En este escenario, el sistema presenta el mensaje de error:

Internal Server Error

Como consecuencia, el proceso de registro del pago no puede completarse correctamente.

Entorno
Cross Segmentos - TOTVS BackOffice (Línea Protheus) - MI - Financiero (SIGAFIN) -  A partir de la versión 12.1.2410

Causa 
Se verificó que el incidente puede presentarse en ambientes que continúan utilizando una versión anterior de la rutina FINA998.

Dicha versión se encuentra descontinuada y no contempla las correcciones y mejoras incorporadas en la nueva arquitectura de la rutina, pudiendo ocasionar errores durante el procesamiento de pagos en moneda extranjera, especialmente en escenarios donde se realizan modificaciones de la tasa de cambio y se gestionan formas de pago o retenciones.

Adicionalmente, el comportamiento puede verse agravado cuando el ambiente no cuenta con las últimas actualizaciones disponibles publicadas por TOTVS.

Solución
Para corregir la incidencia, es necesario migrar a la nueva versión de la rutina FINA998, siguiendo las instrucciones descritas en el boletín técnico correspondiente.

Procedimiento

  1. Verificar que el ambiente se encuentre actualizado con las últimas actualizaciones disponibles en el Portal de Descargas de TOTVS.
  2. Revisar el boletín técnico de implementación de la nueva versión de la rutina FINA998.
  3. Realizar la habilitación y configuración de la nueva versión conforme a las instrucciones documentadas.https://tdninterno.totvs.com/pages/releaseview.action?pageId=874577967
  4. Validar el funcionamiento del proceso de pagos posterior a la implementación.

Resultado

Con la implementación de la nueva versión de la rutina FINA998:

  • Se garantiza la compatibilidad con las correcciones más recientes.
  • Se eliminan los errores asociados a versiones descontinuadas.
  • El registro de formas de pago y retenciones en operaciones con moneda extranjera se procesa correctamente.
  • Se reduce la posibilidad de ocurrencia del error "Internal Server Error" durante la ejecución del proceso.

Recomendación

En caso de requerir asistencia durante la implementación o configuración de la nueva versión, se recomienda contactar al ESN TOTVS, quien podrá brindar apoyo durante el proceso de actualización y puesta en marcha.

¿Fue útil este artículo?
Usuarios a los que les pareció útil: 0 de 0

0 Comentarios

Inicie sesión para dejar un comentario.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Rellene los campos siguientes para iniciar el chat:

Chat _