Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - TOTVS BackOffice (Línea Protheus) - MI - Compras (SIGACOM) - Error "Invalid Field Name DBA_AGENTE" al realizar consulta genérica de la tabla DBA


relogio_tempo_leitura_2.png Tiempo aproximado de lectura 01:00 min 

Ocurrencia
Se identificó una incidencia al ejecutar una Consulta Genérica sobre la tabla DBA, donde el sistema presenta el siguiente mensaje de error:

Invalid field name in Alias DBA->DBA_AGENTE on
{|setVal| IF(setVal==NIL, DBA->DBA_AGENTE,
DBA->DBA_AGENTE:= setVal )}
(MATXFUNB.PRX)

El error impide la correcta visualización y manipulación de la información de la tabla mediante la rutina de Consulta Genérica.

Entorno
Cross Segmentos - TOTVS BackOffice (Línea Protheus) - MI - Compras (SIGACOM) -  A partir de la versión 12.1.2410

Causa 
Se verificó que el problema está relacionado con una configuración incorrecta en el diccionario de datos de la tabla DBA.

Específicamente, el campo DBA_ARMNOM presentaba una definición errónea en su inicializador, donde se informaba el alias BDA en lugar de DBA.

Adicionalmente, se constató que los campos DBA_AGENTE y DBA_ARMNOM no contaban con la configuración adecuada en las opciones de uso del diccionario, lo que ocasionaba que el sistema no reconociera correctamente dichos campos durante la ejecución de la consulta.

Solución
Para corregir la incidencia, se deben realizar los siguientes pasos:

  1. Acceder al configurador de diccionario de datos.
  2. Localizar los campos:
    • DBA_AGENTE
    • DBA_ARMNOM
  3. Eliminar las sentencias actualmente configuradas en el inicializador de ambos campos.
  4. Copiar y configurar los inicializadores correctos conforme a lo indicado en el boletín técnico correspondiente.
  5. Antes de grabar los cambios, validar que en la pestaña Uso de ambos campos se encuentren habilitadas las opciones:
    • Browse
    • Usado
  6. Guardar los cambios y recompilar el diccionario si corresponde.

Con esta corrección, la Consulta Genérica sobre la tabla DBA vuelve a reconocer correctamente los campos involucrados, eliminando el error de tipo Invalid Field Name.

Para consultar la configuración correcta de los inicializadores, revisar el boletín técnico correspondiente disponible en el portal TDN de TOTVS.

 https://tdn.totvs.com/pages/releaseview.action?pageId=984995683
 

 

¿Fue útil este artículo?
Usuarios a los que les pareció útil: 0 de 0

0 Comentarios

Inicie sesión para dejar un comentario.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Rellene los campos siguientes para iniciar el chat:

Chat _