Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - TOTVS BackOffice (Línea Protheus) - MI - Compras (SIGACOM) - MATA143 - Campo F1_EST no considera el Departamento del proveedor para importaciones de Paraguay


relogio_tempo_leitura_2.png Tiempo aproximado de lectura 01:00 min 

Ocurrencia
Se identificó una inconsistencia en el proceso de Despacho del Proceso de Importación de Compras Internacionales (MATA143), utilizado para la generación de la Factura de Entrada del Despacho de Importación.

Durante la creación de la factura, el sistema registraba de forma fija el valor "EX" en el campo Departamento (F1_EST), independientemente de la información configurada para el proveedor.

Este comportamiento afectaba específicamente las operaciones de importación correspondientes a proveedores del país Paraguay, donde el valor esperado para el campo F1_EST debía corresponder al contenido informado en el campo Departamento (A2_EST) del registro del proveedor.

Como consecuencia, la información de ubicación registrada en la factura de entrada no reflejaba correctamente los datos del proveedor.

Entorno
Cross Segmentos - TOTVS BackOffice (Línea Protheus) - MI - Compras (SIGACOM) -  A partir de la versión 12.1.2410

Causa 
La rutina MATA143 contenía una lógica que asignaba de forma fija el valor "EX" al campo Departamento (F1_EST) durante la generación de la factura de entrada para operaciones internacionales.

Debido a esta implementación, no se consideraba el contenido del campo Departamento (A2_EST) del proveedor en los casos específicos de operaciones con proveedores de Paraguay, ocasionando el registro incorrecto de la información.

Solución
Se realizó un ajuste en el proceso Despacho del Proceso de Importación de Compras Internacionales (MATA143) para que el campo Departamento (F1_EST) de la factura almacene el contenido del campo Departamento (A2_EST) del proveedor cuando corresponda.

Para habilitar este comportamiento, fue creada la variable MV_UFFOREX mediante la rutina de Parámetros del configurador (SIGACFG). Este parámetro permite identificar si debe utilizarse el valor del estado/departamento del proveedor en operaciones cuyo país sea Paraguay, sin afectar el tratamiento estándar de los demás países.

Procedimiento

  • Aplicar la solución correspondiente al paquete liberado DMICAS-888.
  • Crear y configurar el parámetro MV_UFFOREX en el ambiente mediante SIGACFG.

Resultado

Con la corrección implementada:

  • El campo F1_EST almacena correctamente el valor informado en A2_EST para proveedores de Paraguay.
  • Se elimina la asignación fija del valor "EX" en este escenario.
  • No se generan impactos en los procesos de importación correspondientes a otros países.

Referencia

Para obtener información adicional sobre la corrección, consulte la documentación oficial asociada al paquete DMICAS-888.

https://tdn.totvs.com/pages/releaseview.action?pageId=990742362

 

¿Fue útil este artículo?
Usuarios a los que les pareció útil: 0 de 0

0 Comentarios

Inicie sesión para dejar un comentario.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Rellene los campos siguientes para iniciar el chat:

Chat _