Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - TOTVS BackOffice (Línea Protheus) - MI - Financiero (SIGAFIN) - Orden de pago - Error log al realizar pago con CBU argument #0 error, expected C->L


relogio_tempo_leitura_2.png Tiempo aproximado de lectura 01:00 min 

Ocurrencia
Error al grabar Orden de Pago Mod. II (FINA850) utilizando documentos con Pago en CBU Informada – mensaje: "argument #0 error, expected C->L, function val on TYPEDATA(MODXFUN.TLPP)"

Entorno
Cross Segmentos - TOTVS BackOffice (Línea Protheus) - MI - Financiero (SIGAFIN) -  A partir de la versión 12.1.2410

Causa 
El inconveniente se origina en la función TypeData() del fuente auxiliar MODXFUN.

La validación de tipos de datos no contemplaba correctamente escenarios donde el modelo esperaba un valor lógico (L), provocando una conversión incorrecta de variables y derivando en el error durante la ejecución del proceso financiero.

Solución
Se realizó un ajuste correctivo en la función TypeData() del fuente MODXFUN.

La corrección consiste en incorporar una condición lógica adicional para manejar adecuadamente los tipos de datos cuando el sistema espera valores lógicos (L), garantizando que la conversión de variables coincida con el tipo de dato definido en la estructura del modelo.

Con este ajuste, el proceso de grabación de la Orden de Pago Mod. II (FINA850) se ejecuta correctamente aun utilizando documentos con Pago en CBU Informada.

¿Fue útil este artículo?
Usuarios a los que les pareció útil: 0 de 0

0 Comentarios

Inicie sesión para dejar un comentario.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Rellene los campos siguientes para iniciar el chat:

Chat _