Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - TOTVS BackOffice (Línea Protheus) - MI - Facturación (SIGAFAT) - D2_USERLGI no es informado en la rutina MATA462AN

relogio_tempo_leitura_2.png Tiempo aproximado de lectura 01:00 min

Ocurrencia
Se presenta un comportamiento incorrecto al generar un remito mediante la rutina MATA462AN, donde el campo Log de Inserción (D2_USERLGI) es completado con la información del usuario que registró el Pedido de Venta (C9_USERLGI), en lugar de registrar el usuario que efectivamente realizó la generación del remito.

Entorno
Cross Segmentos - TOTVS BackOffice (Línea Protheus) - MI - Facturación (SIGAFAT) -   A partir de la versión 12.1.2410

Causa 
El comportamiento ocurría debido a una validación existente en la rutina de Generación de Remito Automático (A462ANGera), donde, al existir los campos:

  • C9_USERLGI en la tabla de Ítems de Pedido de Venta (SC9)
  • D2_USERLGI en la tabla de Ítems de Venta de la Factura (SD2)

El sistema copiaba automáticamente el contenido del campo C9_USERLGI hacia el campo D2_USERLGI, manteniendo el usuario del pedido original en lugar del usuario que realizó el remito.


Solución
Se realizaron ajustes en las siguientes rutinas:

Rutina Generación de Remito (MATA462AN)

En la función:

  • A462ANGera()

fue removida la validación que copiaba automáticamente el contenido del campo:

  • C9_USERLGI → D2_USERLGI

evitando que el log del pedido de venta sea replicado en el remito.

Rutina Notas Fiscales (LOCXNF)

En la función:

  • GravaItensNF()

fue implementada una nueva validación para que, al existir el campo:

  • D2_USERLGI en la tabla SD2, el sistema registre correctamente el usuario que está ejecutando la generación del remito.

Para aplicar la corrección es necesario:

  1. Aplicar el parche correspondiente al issue:
    • DMINA-11579.
¿Fue útil este artículo?
Usuarios a los que les pareció útil: 0 de 0

0 Comentarios

Inicie sesión para dejar un comentario.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Rellene los campos siguientes para iniciar el chat:

Chat _