Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - TOTVS BackOffice (Línea Protheus) - MI - Financiero (SIGAFIN) - Selección automática de NF y NCC en el grid de Totvs Recibo (FINA998) desde la rutina Generac. de Notas de Crédito y Débito (MATA465N)

relogio_tempo_leitura_2.png Tiempo aproximado de lectura 01:00 min

Ocurrencia
Se presenta un error al realizar una compensación posterior a la generación de una Nota de Crédito Cliente (NCC) vinculada a una Factura de Venta (NF). Al acceder a la rutina TOTVS Recibo (FINA998), en el grid de “Nuevo Recibo” únicamente se preselecciona la Nota de Crédito (NCC), mientras que la Factura de Venta (NF) asociada no es marcada automáticamente, obligando al usuario a localizar manualmente la factura entre múltiples registros durante el proceso de compensación.


Entorno
Cross Segmentos - TOTVS BackOffice (Línea Protheus) - MI - Financiero (SIGAFIN) -  A partir de la versión 12.1.2410

Causa 
El comportamiento ocurría debido a que, durante la inicialización del modelo de recibo en la rutina de Cobros Diversos (FINA887.PRW), no existía una lógica específica para identificar automáticamente la relación entre la Nota de Crédito Cliente (NCC) y la Factura de Venta (NF) generada desde la rutina MATA465N.

Como consecuencia, únicamente la NCC era preseleccionada automáticamente en el grid de “Nuevo Recibo”.

Solución
Se realizaron ajustes en la rutina Cobros Diversos (FINA887.PRW), específicamente en la función:

  • IniCargModel()

Con esta mejora, cuando el sistema detecta en la pila de ejecución una llamada proveniente de la rutina:

  • Generación de Notas de Crédito y Débito (MATA465N)

se ejecuta una lógica adicional que permite:

  1. Preseleccionar automáticamente en el grid de “Nuevo Recibo”:
    • Las Notas de Crédito Cliente (NCC)
    • Las Facturas de Venta (NF) asociadas
  2. Mejorar la experiencia del usuario durante el proceso de compensación.
¿Fue útil este artículo?
Usuarios a los que les pareció útil: 0 de 0

0 Comentarios

Inicie sesión para dejar un comentario.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Rellene los campos siguientes para iniciar el chat:

Chat _