Tiempo aproximado de lectura 00:03:00 min
Ocurrencia
Al realizar el reajuste en la lista de precio y modificar un pedido de venta, no se recalcula automáticamente el valor en el Item
Entorno
Cross Segmentos - TOTVS BackOffice (Línea Protheus) - MI - Facturación (SIGAFAT) - A partir de la versión 12
Causa
Este incidente ocurre debido al tratamiento estándar de la rutina MATA410 correspondiente al Pedido de Ventas
Solución
Inicialmente es importante considerar acorde al tratamiento estandar de la rutina de Pedidos de Venta, al modificar el precio de venta de un producto en una lista de precios junto con el manejo de un pedido de venta o presupuesto, el precio unitario de un producto se mantendrá de acuerdo con el valor devuelto por la lista inicialmente y solamente se actualizará al nuevo valor si se modifica la cantidad.
Esto ocurre porque se crea una lista en memoria del producto, cantidad y valor. Este comportamiento tiene como objetivo, además de preservar el desempeño del proceso, garantizar que ítems distintos, que eventualmente tengan el mismo producto y cantidad, no tengan divergencia de valor en un mismo pedido o presupuesto.
0 Comentarios