Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - TOTVS BackOffice (Línea Protheus) - MI - Compras (SIGACOM) - Error.log SXMXXX: TOP Error -19 - [ERROR] (from tDBServer::ROP_CREATEFILE - table SXMXX) Invalid operation with active transaction.

relogio_tempo_leitura_2.png Tiempo aproximado de lectura 00:01:30 min 

Ocurrencia
En el módulo Compras, al intentar realizar la inclusión de una solicitud de compra, se detona error.log:

THREAD ERROR ([13404], raice, LT-RAICES)   06/11/2025 16:28:46
SXM030: TOP Error -19 - [ERROR] (from tDBServer::ROP_CREATEFILE - table SXM030) Invalid operation with active transaction.
( From tDBServer::ROP_CREATEFILE )
Thread ID [16504]    User [consultores]    IO [18376]    Tables [86]    MaxTables [86]    Comment [MATA110 - TCPIP - ThreadID(13404)]    SP [ ]    Traced [No]    SQLReplay [No]    InTran [Yes]    DBEnv [MSSQL/PROTHEUS_QA_CHILE]    DBThread [(SPID 147,148,98)]    Started [06/11/2025 16:27:14]    IP [127.0.0.1:1246]    IDLE [ ]    InTransact [9 s.]    Memory [0]    Running [ROP_CREATEFILE for 0 s.]    RCV [356283]    SND [22893667]    TCBuild [20240224-20250203]    TCVersion [24.1.0.2]    ARCH [64]    OS [WINDOWS]    BUILD [RELEASE]    
on TBIDATASET:CREATETABLE(TBIDATASET.PRW) 

Entorno
Cross Segmentos - TOTVS BackOffice (Línea Protheus) - MI - Compras (SIGACOM) - Versión 12

Causa 
Este incidente puede ser presentado, porque desde la solicitud de compra está detonando un Work Flow y en el ambiente existe algun inconveniente con la creación de tabla SXM.


Solución
Para solucionar esta ocurrencia, realice los siguientes pasos:
1. Si la tabla SXM030 existe, haga un Backup de la misma

2.- Por medio de apsdu realice un Drop a la tabla.

3.- Para regenerar la tabla ejecute los siguientes pasos:

a) Compruebe si hay una cuenta de correo electrónico de WF configurada en el módulo Configurador (Entornos -> Work Flow  -> Cuentas de e-mail) y si está seleccionada en la página Parámetros de flujo de trabajo;

b) Una vez realizadas las validaciones anteriores, ejecute la función estándar WFTEST a través de Smartclient como se muestra en la siguiente documentación.

TDN - WFTEST

c) Después verifique si la tabla fue creada y valide el proceso de inclusión de la SC.

¿Fue útil este artículo?
Usuarios a los que les pareció útil: 0 de 0

0 Comentarios

Inicie sesión para dejar un comentario.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Rellene los campos siguientes para iniciar el chat:

Chat _