Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - TOTVS BackOffice (Línea Protheus) MI - Compras (SIGACOM) - MATA121- Error.log "expected string expression in FieldPut C7_WF in file "D:" at line 819 on MAAVALCOT(COMXFUN.PRX)

Ocurrencia
En módulo de Compras, al intentar generar Pedido de Compra con campo de usuario, se generar error.log :

"expected string expression in FieldPut C7_WF in file D:\bamboo-agent-5.7.2\xml-data\build-dir\TP11-TECX17V3-TECXWIN64\advpl\dbenv.cpp at line 819 on MAAVALCOT(COMXFUN.PRX) 09/10/2020 13:51:48 line : 1383"

Ambiente
Cross Segmentos - TOTVS BackOffice (Línea Protheus) MI - Compras (SIGACOM) – A partir de versión 12


Causa
Este incidente ocurre por definición incorrecta del campo de usuario C7_WF.


Solución

El campo C7_WF no forma parte del diccionario de datos estándar para país Chile. Sin embargo, en caso de ser necesario la implementación de validaciones de Workflow en pedido de compras, la creación del campo C7_WF en tabla SC7 deberá ser obligatoriamente de tipo lógico, debido a la integración con el campo C8_WF incluido en tabla SC8.

Para corregir el incidente realice los siguientes pasos:

1. Realizar respaldo de diccionario de datos.

2. Ingresar al módulo Configurar y borrar el campo C7_WF (en caso de que ya exista en la tabla SX3).

3. Ingresar nuevamente al módulo Configurador para incluir C7_WF conforme a la misma estructura del campo estándar C8_WF de la tabla SC8, garantizar que el tipo de campo sea Lógico.

mceclip0.png

mceclip1.png

mceclip2.png

mceclip3.png

mceclip4.png

mceclip5.png

mceclip6.png

4. Confirmar la actualización de base de datos.

5. Realizar las validaciones correspondientes y verificar que el error.log es corregido.

 

¿Fue útil este artículo?
Usuarios a los que les pareció útil: 0 de 0

0 Comentarios

Inicie sesión para dejar un comentario.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Rellene los campos siguientes para iniciar el chat:

Chat _