Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - TOTVS BackOffice (Línea Protheus) MI - Compras (SIGACOM) - MATA121 Error.log DBDelete - Lock required on A120GRAVA(MATA120.PRX) en borrado de pedido de compra

Ocurrencia
En módulo Compras en rutina MATA121-Pedidos de compra, al intentar borrar un Pedido, se genera error.log: DBDelete - Lock required on A120GRAVA(MATA120.PRX)

mceclip0.png

 

Ambiente
Cross Segmentos - TOTVS BackOffice (Línea Protheus) MI - Compras (SIGACOM) – A partir de versión 12

Causa
Este incidente ocurre, por inconsistencias a nivel código cuando se intenta borrar pedido ligado a una solicitud y el parámetro MV_TTS se encuentra deshabilitado.


Solución

Para solucionar esta ocurrencia siga los siguientes pasos:

1. Verifique que la fecha de la rutina MATA120 se encuentre con fecha igual o superior al 05/06/2020.

2. En caso de no tener la rutina actualizada, deberá descargar el paquete de actualización según la versión/release correspondiente de su ambiente, y aplicarlo inicialmente en un ambiente controlado para pruebas, con previo respaldo del repositorio(RPO).

- PATCH 12.1.27: PACOTE_DE_CORRECAO_8991014_DMANMAT02-27921_12.1.27
- PATCH 12.1.25: PACOTE_DE_CORRECAO_8991014_DMANMAT02-27921_12.1.25
- PATCH 12.1.23: PACOTE_DE_CORRECAO_8991014_DMANMAT02-27921_12.1.23

3. Ingrese a la rutina MATA121-Pedidos de Compra y confirme que puede realizar de forma satisfactoria el borrado del Pedido de Compra.

 

Conozca más:

TDN - DMANMAT02-27921 DT MATA120 Errorlog ao apagar um pedido de compra com MV_TTS desativado.

Para mayor información referente a aplicación de PATCH, le recomendamos revisar el siguiente artículo:
MP - CFG - Aplicación de Patch con Visual Studio Code (VS Code)

 

¿Fue útil este artículo?
Usuarios a los que les pareció útil: 0 de 0

0 Comentarios

Inicie sesión para dejar un comentario.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Rellene los campos siguientes para iniciar el chat:

Chat _