FAQs - Suporte técnico

Cross Segmentos - TOTVS BackOffice (Línea Protheus) MI - Financiero (SIGAFIN) - FINA846. Error.log: variable is not array - Type [C] on REFDATA(FINA840.PRW)

Ocurrencia
En módulo Financiero, al intentar realizar un cobro diverso se presenta error.log "variable is not array - Type [C] on REFDATA(FINA840.PRW)"

mceclip0.png

Ambiente
Cross Segmentos - TOTVS BackOffice (Línea Protheus) MI - Financiero (SIGAFIN) – A partir de versión 12

Causa
Este incidente ocurre, por inconsistencias a nivel código en el programa fuente FINA840, cuando en la ejecución de la rutina cobros diversos se configura la pregunta ¿Considera Sucursal?=No


Solución

Para solucionar esta ocurrencia, verifique que la rutina FINA840 se encuentre con fecha igual o superior al 23/10/2020.

1. Confirmar que la fecha de la rutina FINA840 se encuentre con fecha igual o superior al 23/10/2020.

2. En caso de no tener la rutina actualizada, deberá descargar el paquete de actualización según la versión/release correspondiente de su ambiente, y aplicarlo inicialmente en un ambiente controlado para pruebas, con previo respaldo del repositorio(RPO).

- PATCH 12.1.27: PACOTE_DE_CORRECAO_10036361_DMICNS-9603_12.1.27
- PATCH 12.1.25: PACOTE_DE_CORRECAO_10036361_DMICNS-9603_12.1.25
- PATCH 12.1.23: PACOTE_DE_CORRECAO_10036361_DMICNS-9603_12.1.23

 

3. Ingrese a la rutina FINA846 - Cobros Diversos II valide la ejecución de la consulta y confirme que el error.log no es presentado.

Conozca más:
Consulte el boletín técnico de la liberación homologada:

TDN - DMICNS-9603 DT Error en la rutina Cobranzas diversas II ARG
Para mayor información referente a aplicación de PATCH, le recomendamos revisar el siguiente artículo:
MP - CFG - Aplicación de Patch con Visual Studio Code (VS Code)

¿Fue útil este artículo?
Usuarios a los que les pareció útil: 0 de 0

0 Comentarios

Inicie sesión para dejar un comentario.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Rellene los campos siguientes para iniciar el chat:

Chat _