FAQs - Suporte técnico

Cross Segmentos - TOTVS BackOffice (Línea Protheus) - MI - Configurador (SIGACFG) - Array out of bounds [1] of [0] on AXPESQUI(MATXATU.PRX)

Ocurrencia
Al usar la función AxCadastro() e intentar realizar una búsqueda a través de la opción Otras Acciones >> Buscar, se presenta el siguiente error log:

"Array out of bounds [1] of [0] on AXPESQUI(MATXATU.PRX)"


Ambiente
Cross Segmentos - TOTVS BackOffice (Línea Protheus) - MI - Configurador (SIGACFG) - A partir de la versión 11

Causa
El error es ocasionado porque no existen índices configurados para la tabla que está siendo utilizada en la función AxCadastro. 

Solución
Para solucionar el error log, deberá realizar el siguiente procedimiento:

 

1. Ingresar al módulo Configurador (SIGACFG).

 

2. A través de la opción Base de Datos (Base de Datos >> Diccionario), identificar y editar la tabla utilizada en la función AxCadastro.

 

3. Crear y/o configurar un índice para la búsqueda. Ejemplo:

mceclip0.png

 

4. Grabar los cambios al diccionario de datos.

 

5. Una vez ajustada la configuración del diccionario de datos, confirmar que sea posible realizar la búsqueda en la función de usuario (AxCadastro). Ejemplo:

mceclip1.png

 

¿Fue útil este artículo?
Usuarios a los que les pareció útil: 0 de 0

0 Comentarios

Inicie sesión para dejar un comentario.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Rellene los campos siguientes para iniciar el chat:

Chat _