Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - TOTVS BackOffice (Línea Protheus) MI - Stock y Costos (SIGAEST) - MATA241: Error.log: array out of bounds on A250INIOP(MATA250.PRX)

Ocurrencia
En el módulo de Stock/Costos, al intentar registrar un movimiento interno múltiple desde la rutina MATA241 asociado a una Orden de Producción, es presentado el error log "array out of bounds ( 0 of 57 ) on A250INIOP(MATA250.PRX)"  luego de informar el campo D3_OP- Ord. Prodn.

mceclip0.png


Ambiente
Cross Segmentos - TOTVS BackOffice (Línea Protheus) MI - Stock y Costos (SIGAEST) – A partir de la versión 12

Causa
El error "array out of bounds ( 0 of ... )" comúnmente se presenta cuando algún campo del arreglo no está disponible; ya sea por que el campo no está marcado como "usado" en el sistema,  porque el campo tenga un nivel superior al de usuario, o cuando no está marcado para utilizar en todos los módulos.


Solución
Para solucionar esta ocurrencia, realice los siguientes pasos:
1. Realice un respaldo de la tabla SX3 del ambiente donde réplica este comportamiento, específicamente para la tabla SD3.


2. Desde el módulo Configurador - SIGACFG, verifique que los siguientes campos estén en uso y configurados como nivel 1 (conforme al diccionario estándar):

  • D3_TRT - Sec. Estruct
  • D3_OP - Ord. Prodn.
  • D3_COD - Codigo del Producto
    Ejemplo campo D3_TRT:

mceclip2.png

mceclip1.png

mceclip3.png

3. En caso de identificar algún campo con configuración diferente, realice los ajustes y grabe las modificaciones en modo exclusivo 

4.- Realice una nueva validación para la inclusión del movimiento múltiple asociado a Orden de  Producción y confirme la corrección del error.log

¿Fue útil este artículo?
Usuarios a los que les pareció útil: 0 de 0

0 Comentarios

Inicie sesión para dejar un comentario.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Rellene los campos siguientes para iniciar el chat:

Chat _