Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - TOTVS BackOffice (Línea Protheus) MI - Compras (SIGACOM) - Factura vinculada a Remito: array out of bounds on SCMTOREM(LOCXNF.PRW)

Ocurrencia
En módulo de Compras, al intentar realizar una Factura de Entrada en rutina MATA101N vinculado a un remito de Entrada, utilizando la opción  Otras Acciones>Remito y posteriormente el botón Remito
mceclip0.png

mceclip1.png

Se detona el error.log "array out of bounds [117] of [116] on SCMTOREM(LOCXNF.PRW)"

Ambiente
Cross Segmentos - TOTVS BackOffice (Línea Protheus) MI - Compras (SIGACOM) – A partir de versión 12

Causa
Este error, regularmente se presenta debido a que el arreglo armado dentro de la función SCMTOREM no está siendo completado con los campos correspondientes llamados por la rutina LOCXNF.

Solución
Para solucionar esa ocurrencia, realice los siguientes pasos:

1.- Verificar y garantizar que los siguientes campos se encuentren con la propiedad de "Usado"

A nivel encabezado: F1_FILIAL, F1_DOC, F1_SERIE, F1_FORNECE, F1_LOJA, F1_TIPO
A nivel detalle: D1_DOC, D1_SERIE, D1_FORNECE, D1_LOJA, D1_REMITO, D1_SERIREM, D1_ITEMREM

mceclip2.png

¿Fue útil este artículo?
Usuarios a los que les pareció útil: 1 de 1

1 Comentarios

  • Avatar
    ALFREDO CASALINO

    El mismo error se detona cuando se llama a un remito de devolución. Para ello, los campos D2_DOC, D2_SERIE, D2_CLIENTE, D2_LOJA, D2_REMITO, D2_SERIREM, D2_ITEMREM, D2_ITEMORI tienen que seguir el mismo criterio expuesto en este artículo.

    0
    Acciones de comentarios Permalink
Inicie sesión para dejar un comentario.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Rellene los campos siguientes para iniciar el chat:

Chat _