Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - TOTVS BackOffice (Línea Protheus) MI - Contabilidad de Gestión (SIGACTB) - Error.log: InterFunctionCall: cannot find function CTBCHKDIF in AppMap on CTBA102LAN(CTBA102.PRW)

Ocurrencia
En módulo Contabilidad, al intentar realizar un asiento, se detona mensaje que posteriormente:

mceclip0.png

InterFunctionCall: cannot find function CTBCHKDIF in AppMap on CTBA102LAN(CTBA102.PRW)

 
Ambiente
Cross Segmentos - TOTVS BackOffice (Línea Protheus) MI - Contabilidad de Gestión (SIGACTB) – A partir de versión 12

Causa
El incidente ocurre puede ocurrir por alguna actualización aislada de las rutinas de contabilidad, en este caso la rutina CTBA102 a partir de la fecha 17/02/2020 hace llamada a la función "CTBCHKDIF" la cual se encuentra compilada en la rutina CTBA105, si la rutina CTBA105 se encuentra desactualizada, será generado el error.

Solución
Para solucionar esta ocurrencia, verifique que la rutina CTBA105 se encuentre con fecha igual o superior al 17/02/2020.

1. Verifique que la fecha de la rutina CTBA105 se encuentre con fecha igual o superior al 17/02/2020.

2. En caso de no tener la rutina actualizada, deberá descargar el paquete de actualización según la versión/release correspondiente de su ambiente, y aplicarlo inicialmente en un ambiente controlado para pruebas, con previo respaldo del repositorio(RPO)
- PATCH 12.1.23: PACOTE_DE_CORRECAO_7986107_DSERCTR1-25598_12.1.23
- PATCH 12.1.25: PACOTE_DE_CORRECAO_7986107_DSERCTR1-25598_12.1.25

3. Ingrese a la rutina CTBA102 para incluir el asiento requerido y confirme que el error.log no es presentado.

Conozca más:
Para mayor información referente a aplicación de PATCH, le recomendamos revisar el siguiente artículo:
MP - CFG - Aplicación de Patch con Visual Studio Code (VS Code)

¿Fue útil este artículo?
Usuarios a los que les pareció útil: 0 de 0

0 Comentarios

Inicie sesión para dejar un comentario.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Rellene los campos siguientes para iniciar el chat:

Chat _