Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - TOTVS BackOffice (Línea Protheus) MI - Contabilidad de Gestión (SIGACTB) - CTBA060 - Help: JAGRAVADO - Cannot insert duplicate key row in object 'dbo.CTH020' with unique index 'CTH020_UNQ'.



Ocurrencia
En el módulo de Contabilidad de Gestión (SIGACTB) al incluir una Clase Valor (CTBA060) con un código ya existente en la tabla CTH, no es presentado el mensaje de validación Help: JAGRAVADO, permite grabar el registro donde se presenta el error.log: 

Cannot insert duplicate key row in object 'dbo.CTH020' with unique index 'CTH020_UNQ'.


Ambiente
Cross Segmentos - TOTVS BackOffice (Línea Protheus) MI - Contabilidad de Gestión (SIGACTB) - Versión 12


Causa
Este incidente ocurre por inconsistencias de informacion originado por dato migrados o importados con minúsculas, cuando el sistema Protheus al momento de grabar los datos los hace en mayúsculas; Por este motivo no es detonado el mensaje de validación Help: JAGRAVADO permitiendo la grabación y generando el error.logr.

Ejemplo de error:

CTH020: DB error (Update): -29 File: CTH020 - Error : 2601 (23000) (RC=-1) - [Microsoft][SQL Server Native Client 11.0][SQL Server]Cannot insert duplicate key row in object 'dbo.CTH020' with unique index 'CTH020_UNQ'. The duplicate key value is (01, EM200127 , 0).

UPDATE dbo.CTH020 SET D_E_L_E_T_ = ?,R_E_C_D_E_L_ = ? WHERE R_E_C_N_O_ = ?
-- Binded Parameters List --
#1 [C] [ ]
#2 [N] [0.000000]
#3 [N] [11282.000000]
on ENDTRAN(APLIB060.PRW) 18/05/2020 17:21:57 line : 224

Clase Valor existente en el tabla CTH en minúsculas (Dato migrado o importado)

mceclip0.png



Solución
Para solucionar esta ocurrencia, realice los siguientes pasos:

1. Ingrese por APSDU a la tabla CTH y realice el respaldo de la tabla con la opción Copy To del menú utilitario;


2.
Después deberá filtrar por el campo CTH_CVLVL igual al código existente en el tabla CTH";

3. Deberá cambiar las letras minúsculas por mayúsculas, cerrar la tabla y salir por APSDU;

  • Importante: El FIX de la base de datos queda fuera del alcance de soporte TOTVS al producto estándar, estas actividades deberán ser realizadas por el DBA o administrador del ambiente Protheus en el cliente.



4. Una vez hecho el ajuste en el registro que origina el error de duplicidad en su tabla CTH,, ingrese a la rutina Clase Valor (CTBA060), incluya la clase valor con el código, valide que sea presentado el mensaje de validación Help: JAGRAVADO al momento de ingresar el código en el campo CTH_CVLVL.

mceclip0.png

mceclip1.png

mceclip2.png

 

Conozca más:
Para consultar la información contenida en nuestro banco de conocimientos, acceda al siguiente enlace:

Help On-Line - Clase Valor (CTBA060

¿Fue útil este artículo?
Usuarios a los que les pareció útil: 0 de 0

0 Comentarios

Inicie sesión para dejar un comentario.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Rellene los campos siguientes para iniciar el chat:

Chat _