Ocurrencia
En el uso de funcionalidad M-Messenger para el evento de inclusión de producto no se realiza el envío de e-mail.
Ambiente
Cross Segmentos - TOTVS BackOffice (Línea Protheus) - MI - Configurador (SIGACFG) – A partir de versión 12
Causa
Este incidente puede ocurrir por errores en las configuraciones de Protheus, o por configuraciones de privacidad en el servidor de e-mail que tiene bloqueo de DNS. En el caso de este artículo, se indicarán las configuraciones para un servidor de gmail.
Solución
Para solucionar esta ocurrencia, revise las siguientes configuraciones:
1. En el módulo Configurador, ingrese a la opción Entorno>E-mail/proxy>Configurar y confirme la correcta configuración.



2. En el módulo Configurador, en el apartado Usuario>Contraseñas>Usuarios configure el e-mail para el usuario correspondiente.

3. En el módulo Configurador, a través de la opción Entorno>Archivos>Parámetros revise los parámetros de configuración:
- MV_EMCONTA: Indica que cuenta es utilizada para envío de e-mails automáticos por el sistema. 
- MV_EMSENHA: Indica cual es la clave de cuenta utilizada para envió de e-mails automáticos por el sistema.
- MV_RELAUSR: Usuario para Autenticacion en el Servidor de Email
- MV_RELSERV: Nombre de Servidor de Envio de E-mail utilizado en los informes
- MV_RELAUTH: Determina si el servidor requiere Autenticacion.

4. En rutina MATA045-M-messenger incluir el evento de inclusión de Producto en usuario correspondiente.
5. Revisar las Configuraciones de la cuenta de correo que se ha configurado para el envío de e-mail, ya que algunos servidores de correo electrónico como es el caso de GMAIL, tienden a tener un bloqueo de DNS que verifica el acceso para posibles aplicaciones inseguras y bloquea la autenticación del envío de correo electrónico. En tales casos, es necesario liberar el acceso en la configuración del correo electrónico.
- Ingrese a la cuenta y Active la opción de "Acceso a Aplicaciones Menos Seguras"



6. Ingresar al Módulo de Compras y confirmar que en la inclusión de Producto se envíe el e-mail correspondiente acorde a las configuraciones, y el mensaje inicial ya no se presenta.

- Confirmación de e-mail

0 Comentarios