Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - TOTVS BackOffice (Línea Protheus) MI - Compras (SIGACOM) - MATA101n. Error.log: expected string expression in FieldPut F3_ENTRADA in file

Ocurrencia
En módulo compras, al intentar incluir una factura manual en rutina MATA101n se genera error.log:

"expected string expression in FieldPut F3_ENTRADA in file D:\bamboo-agent-5.7.2\xml-data\build-dir\TP11-TECX17V3R1-TECXWIN64\advpl\dbenv.cpp at line 815
on XFISATUSF3(IMPXFIS.PRW)"

mceclip0.png


Ambiente
Cross Segmentos - TOTVS BackOffice (Línea Protheus) MI - Compras (SIGACOM) – A partir de versión 12

Causa
Este incidente ocurre debido a que el campo F3_ENTRADA tiene una definición incorrecta en el diccionario de datos, el campo por estándar es un campo de tipo fecha.

Solución
Para solucionar esta ocurrencia, realice los siguientes pasos:
1. Realizar un respaldo de tabla SX3 y SF3 del ambiente donde replica el inconveniente.
2. A través de apsdu realizar el Drop de la tabla SF3
3. Ingresar al módulo Configurador y confirmar que el campo F3_ENTRADA esté definido como tipo fecha.
mceclip0.png

4. Ingresar a la rutina MATA101n-Factura de entrada y dar click en el botón incluir para que se cree nuevamente la tabla SF3
5. Appende los datos respaldados en el paso 1 de la tabla SF3.
6. Ingresar nuevamente a la inclusión de Factura de Entrada y confirmar que el error.log es corregido.

¿Fue útil este artículo?
Usuarios a los que les pareció útil: 0 de 0

0 Comentarios

Inicie sesión para dejar un comentario.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Rellene los campos siguientes para iniciar el chat:

Chat _