Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

FRAMEWORK - Framework (Línea Protheus) MI - DBACCESS - Table TOP_PARAM field PARAM_SESSION check failed



Ocurrencia
Al iniciar la conexión de DBAccess al banco, aparece el siguiente mensaje: Table TOP_PARAM field PARAM_SESSION check failed

mceclip0.png


Ambiente
FRAMEWORK - Framework (Línea Protheus) MI – A partir de versión Versión12
TOTVS | DBAccess - A partir de la versión 42.20141119


Causa
A través de la función tcSetParam (), una aplicación AdvPL puede incluir o alterar un parámetro en la tabla TOP_PARAM, y ese parámetro está relacionado con el usuario a través de su ID en la base de datos.

Si el tipo de datos utilizado para el campo PARAM_SESSION no contiene la información, se presenta el error "Tabla TOP_PARAM field PARAM_SESSION check failure".



Solución
Para solucionar esta ocurrencia, realice los siguientes pasos:

1. Evaluar la actualización de DBAPI en la (s) carpeta (s) de AppServer;
TDN - DBAccess - Como actualizar el DBAccess y el DBAPI

2. Finalice todas las instancias de DBAccess, garantice tener la última actualización de este componente;

3. Respalde y después elimine la tabla TOP_PARAM a través de las herramientas de administración del motor de la base de datos;

4. Reinicie el DBAcces y servicios de Protheus, valide el acceso al ambiente.


Conozca más:
Para consultar la información contenida en nuestro banco de cocimientos, acceda a los siguientes enlaces:  TDN - Tipo de dato PARAM_SESSION incompatible con dato insertado

¿Fue útil este artículo?
Usuarios a los que les pareció útil: 0 de 0

0 Comentarios

Inicie sesión para dejar un comentario.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Rellene los campos siguientes para iniciar el chat:

Chat _