Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

TOTVS MANUFACTURA - TOTVS Manufactura (Línea Protheus) - MI - Mantenimiento de Activos (SIGAMNT) - MNTA120 - Problema en el índice único de las tablas TPF, TP5, TPG, TPM, TPH, STC o TP2. De esta manera, el parámetro MV_NGMNTFR (Utiliza Flota)



Ocurrencia
En el módulo de Mantenimiento de activos (SIGAMNT) al incluir un Mantenimiento (MNTA120), se presenta un mensaje que nos permite continuar con la operación:

Atención se identificó un problema en el índice único de las tablas TPF, TP5, TPG, TPM, TPH, STC o TP2. De esta manera, el parámetro MV_NGMNTFR (Utiliza Flota) se considera como N-No utiliza

mceclip0.png



Ambiente
TOTVS MANUFACTURA - TOTVS Manufactura (Línea Protheus) - MI - Mantenimiento de Activos (SIGAMNT) - Versión 12

Causa
Este incidente ocurre por la activación del parámetro MV_NGMNTFR = S, para la integración de la Gestión de Flotas con el módulo de mantenimiento de activos.

Solución
Para solucionar esta ocurrencia, realice los siguientes pasos:

1. Verificar tiene implementada la funcionalidad de Gestión de Flotas, caso contrario deberá configurar el parámetro MV_NGMNTFR = N;


2. Si tiene implementada la funcionalidad de gestión de flotas (MV_NGMNTFR = S), el campo TP9_TIPMOD deja de pertenecer a la llave única de la tabla y solamente es posible registrar un bien estándar por familia impactando los índices de las otra tablas TPB y TPK;


3. En un ambiente de pruebas realice el ajuste en el índice único (X2_UNICO) de las tablas TPF, TP5, TPG, TPM, TPH, STC o TP2, recuerde dropear las tablas desde APSDU una vez que fueron respaldadas para que sean regeneradas con el índice único ajustado; 

 

  • TPF_FILIAL+TPF_CODFAM+TPF_TIPMOD+TPF_SERVIC+TPF_SEQREL

  • TP5_FILIAL+TP5_CODFAM+TP5_TIPMOD+TP5_SERVIC+TP5_SEQREL+TP5_TAREFA

  • TPG_FILIAL+TPG_CODFAM+TPG_TIPMOD+TPG_SERVIC+TPG_SEQREL+TPG_TAREFA+TPG_TIPORE+TPG_CODIGO

  • TPM_FILIAL+TPM_CODFAM+TPM_TIPMOD+TPM_SERVIC+TPM_SEQREL+TPM_TAREFA+TPM_DEPEND 

  • TPH_FILIAL+TPH_CODFAM+TPH_TIPMOD+TPH_SERVIC+TPH_SEQREL+TPH_TAREFA+TPH_ETAPA

  • TC_FILIAL+TC_CODBEM+TC_TIPMOD+TC_COMPONE+TC_TIPOEST+TC_LOCALIZ+TC_SEQRELA

  • TP2_FILIAL+TP2_CODFAM+TP2_TIPMOD+TP2_SERVIC+TP2_SEQREL+TP2_TAREFA+TP2_ETAPA+TP2_OPCAO   

 


4. Al activar la integración con la funcionalidad Gestión de Flotas, se deberá hacer la reconfiguración total del ambiente utilizando el programa UPDDISTR para llevar a cabo los ajustes de diccionario de datos correspondientes. Adjunto los siguientes enlaces con información relevante a la integración de Mantenimiento de Activos con Gestión de Flotas:



5. Se sugiere descargue el archivo de actualizaciones acumuladas del módulo SIGAMNT para Protheus en la versión/ release de Protheus en su ambiente;


6. Una vez aplicadas las actualizaciones y los ajustes en el índice, valide el escenario reportado y los resultados generados.


Conozca más:
Para consultar la información contenida en nuestro banco de conocimientos, acceda al siguiente enlace:

Help On-Line: Mantenimiento/Monitoreo (MNTA120)

¿Fue útil este artículo?
Usuarios a los que les pareció útil: 0 de 0

0 Comentarios

Inicie sesión para dejar un comentario.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Rellene los campos siguientes para iniciar el chat:

Chat _