Ocurrencia
En el acceso al sistema Protheus se genera un error.log:
Acceso - SIGAPSS.SPF: Create SuperFile - Ctree Error 17 - IO Error: 3 - Could not create data file File: sigapsf.spf on _APPSWIMPORT(SIGAPSW.PRG) 06/01/2020 18:18:02 line : 2118
Ambiente
FRAMEWORK - Framework (Línea Protheus) MI – A partir de versión 12
Causa
Este incidente puede ocurrir porque el archivo de usuarios sigapss.spf se corrompió y/o porque el servidor del CTREESERVER no esta en el mismo servidor que el servicio de Protheus.
Solución
Para solucionar esta ocurrencia, realice los siguientes pasos:
- Garantice que el servidor del CTREESERVER este en el mismo servidor donde está el servidor de Protheus es decir el appserver.exe; TOTVS recomienda usar el servidor Ctree en el mismo servidor que la aplicación Protheus para evitar conflictos y fallas en la red, donde puede causar errores en el acceso al ambiente como es el indicado en este artículo;
- Garantice que las carpetas contenidas en el Protheus_Data del ambiente tengan permiso de lectura y escritura en especial las carpetas PROFILE y SYSTEM;
- Otorgue permiso por completo en la carpeta del system;
- Detener el servicio del sistema Protheus;
- Acceda a la carpeta del system dentro de protheus_data, renombre el archivo sigapss.spf ;
- Renombre el nombre de los archivos de ayuda (* .hlp * .hls * .hle) contenidos en la carpeta system del ambiente;
- Garantice tener los archivos del Help Completos y Diferencial localizados para el país y versión/release de Protheus en la carpeta systemload contenida en el Protheus_Data del ambiente;
- Se sugiere descargue el archivo de librerías acorde a la versión de su ambiente, 20-01-06-LIB_LABEL_06012020_P12; Aplicar las actualizaciones en su ambiente de pruebas inicialmente, con previo respaldo del RPO y eligiendo la opción "Aplicar solo fuentes actualizados";
Ambiente 32 para versión/release 12117 o inferior
* Portugués - https://suporte.totvs.com/portal/p/10098/download?e=899723
* Inglés - https://suporte.totvs.com/portal/p/10098/download?e=899725
* Espanhol - https://suporte.totvs.com/portal/p/10098/download?e=899724
Ambiente Lobo para versión/release 12.123 o superior
* Portugués - https://suporte.totvs.com/portal/p/10098/download?e=899720
* Inglés - https://suporte.totvs.com/portal/p/10098/download?e=899722
* Espanhol - https://suporte.totvs.com/portal/p/10098/download?e=899721 - Detener el servicio del servidor CtreeServer;
- Elimine los archivos de índice de Protheus (* .CDX , *.IDX y * .IND) de Protheus que están en la carpeta SYSTEM o equivalente;
- Eliminar el contenido de la carpeta CTREEINT, creada dentro de la carpeta SYSTEM;
- Elimine los archivos de índice Protheus (* .CDX) que están en la carpeta PROFILE instanciada en PROTHEUS_DATA;
- Eliminar el contenido de la carpeta CTREEINT, creada dentro de la carpeta PROFILE;
- Elimine los archivos con la extensión * .FCS de la carpeta donde está instalado CtreeServer (lo ideal es crear una carpeta para guardarlos para copias de seguridad y análisis futuros pero eliminándolos de la carpeta original);
- Subir el CtreeServer;
- Subir al menos un servicio Protheus, en caso de que exista el balanceo;
- Realice el acceso STAND ALONE (solo) en el sistema para que se creen los índices y así evitar la concurrencia en el sistema. Si hay más empresas, debe ingresar una por una para crear los índices de cada empresa. Puede usar el Módulo Configurador para crear los índices porque no carga las tablas de la base de datos y, por lo tanto, será más rápida la liberación del sistema;
- Después de crear todos los índices para todas las empresas, salga del Módulo al que se accedió;
- Detenga el servicio CtreeServer y después suba el servicio nuevamente (reinicio);
- Subir los servicios de Protheus y liberar el acceso a los usuarios.
Nota: Si el error.log se presenta para un usuario de Protheus en específico, deberá validar los siguientes puntos adicionales en el módulo configurador (sigacfg):
A) Menú: Entorno-> Registros-> Perfil de mantenimiento;
MP - CFG - PROFMGR - Perfil del usuario Mantenimiento (Profile)
B) Haga clic en buscar;
C) Seleccione este usuario que está dando un error;
D) Haga clic en Eliminar-> Seleccione la opción: Todos los registros de usuarios;
E) Realice una prueba accediendo nuevamente a la rutina que estaba dando error.
Conozca más:
Para consultar la información contenida en nuestro banco de conocimientos, acceda al siguiente enlace:
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