Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

FRAMEWORK - Framework (Línea Protheus) MI - CTREEServer - Data base files can only be created on the server on GERAINS(MSLIB.PRW) 06/07/2011 16:02:25 line : 3152


Ocurrencia
En la ejecución de diversas rutinas de Protheus se genera el error.log:

Data base files can only be created on the server on GERAINS(MSLIB.PRW) 06/07/2011 16:02:25 line : 3152


Ambiente
FRAMEWORK - Framework (Línea Protheus) MI – A partir de versión 10


Causa
Situación causada por la corrupción de los datos del CTREE Server.


Solución
Para solucionar esta ocurrencia, realice los siguientes pasos para la limpieza del CTREEServer:

  1.  Detener el servicio del servidor CtreeServer;

  2. - Elimine los archivos de índice de Protheus (* .CDX , *.IDX y * .IND) de Protheus que están en la carpeta SYSTEM o equivalente;

  3. - Eliminar el contenido de la carpeta CTREEINT, creada dentro de la carpeta SYSTEM;

  4. - Elimine los archivos de índice Protheus (* .CDX) que están en la carpeta PROFILE instanciada en PROTHEUS_DATA;

  5. - Eliminar el contenido de la carpeta CTREEINT, creada dentro de la carpeta PROFILE;

  6. - Elimine los archivos con la extensión * .FCS de la carpeta donde está instalado CtreeServer (lo ideal es crear una carpeta para guardarlos para copias de seguridad y análisis futuros pero eliminándolos de la carpeta original);

  7. - Subir el CtreeServer;

  8. - Suba al menos un servicio Protheus en caso de que exista el balanceo;

  9. - Realice el acceso STAND ALONE (solo) en el sistema para que se creen los índices y así evitar la concurrencia en el sistema. Si hay más empresas, debe ingresar una por una para crear los índices de cada empresa. Puede usar el Módulo Configurador para crear los índices porque no carga las tablas de la base de datos y, por lo tanto, será más rápida la liberación del sistema;

  10. - Después de crear todos los índices para todas las empresas, salga del Módulo al que se accedió;

  11. - Detenga el servicio CtreeServer y después suba el servicio nuevamente (reinicio);

  12. - Subir los servicios de Protheus y liberar el acceso a los usuarios.


Conozca más:

Para consultar la información contenida en nuestro banco de conocimientos, acceda al siguiente enlace:
TDN: Limpeza C-Tree

 

¿Fue útil este artículo?
Usuarios a los que les pareció útil: 0 de 0

0 Comentarios

Inicie sesión para dejar un comentario.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Rellene los campos siguientes para iniciar el chat:

Chat _