Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

FRAMEWORK - Framework (Línea Protheus) - MI - Type mismatch on .AND. on CHKEJECTBEFORE(MSSPOOL.PRW)

Ocurrencia
Se presenta el siguiente error log al intentar realizar la impresión de un informe: 

"THREAD ERROR ([12412], luis.samaniego, HELP2018CFSJ2) 26/11/2019 10:48:01
type mismatch on .AND. on CHKEJECTBEFORE(MSSPOOL.PRW) 18/11/2019 18:56:05 line : 1716"

Ambiente
FRAMEWORK - Framework (Línea Protheus) - MI - A partir de versión 12.1.17

Causa
El error log es ocasionado por un error en la definición del parámetro MV_CANSALT, el parámetro fue creado con tipo de dato fecha (D), lo cual no es correcto.

Solución
Para dar solución a este incidente, deberá alterar el tipo de dato del parámetro MV_CANSALT. Este parámetro debe estar definido con un tipo de dato lógico (L).

Definición correcta del parámetro MV_CANSALT:

mceclip0.png

En caso de que no se permita realizar la corrección a través del modulo Configurador (SIGACFG), deberá ingresar vía APSDU y modificar la propiedad X6_TIPO para el parámetro MV_CANSALT.

¿Fue útil este artículo?
Usuarios a los que les pareció útil: 0 de 0

0 Comentarios

Inicie sesión para dejar un comentario.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Rellene los campos siguientes para iniciar el chat:

Chat _