Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

TOTVS RH - TOTVS RH (Línea Protheus) MI - Reloj registrador electrónico (SIGAPON) - Modelo II - PONA160 – Cambio de Turno - cannot find function in AppMap on F3MONTAFILTRO(MSLIB.PRW) 12/07/2019 17:27:31 line : 8068



Ocurrencia
En el módulo de Reloj Registrador Electrónico (SIGAPON), en la rutina Cambio de Turno (PONA160), al ingresa una secuencia de turno destino, se genera el error.log: 

InterFunctionCall: cannot find function RF2FILCONPAD in AppMap on F3MONTAFILTRO (MSLIB.PRW) 12/07/2019 17:27:31 line : 8068


Ambiente
TOTVS RH - TOTVS RH (Línea Protheus) MI - Reloj registrador electrónico (SIGAPON) - Modelo II - A partir de la versión 12


Causa
Este incidente puede ocurrir por no tener compilas las rutinas Pivotes del módulo de SIGAPON correspondientes a países de Mercado Internacional, por haber aplicado actualizaciones de la Suite de RH del país Brasil o bien por inconsistencias en el registro de la tabla de Horario Estándar.


Solución
Para solucionar esta ocurrencia, realice los siguientes pasos:

1. En el error.log reportado se observa la fecha 25/10/2019 para la rutina PONA160

  • Es importante recordarle que no debe aplicar ninguna actualización, mensual, semanal o acumulado de RH que están disponibles en el portal del cliente, ya que estas actualizaciones corresponden a funcionalidad del país Brasil.

  • Si aplico alguna de esta actualizaciones, deberá quitarlas de su RPO, colocar el RPO Estándar para países de Mercado Internacional, aplicar patch de librerías y con este validar el escenario reportado.


2. Corrobore tener las siguientes fechas en las rutinas; En caso de que tenga otras fechas, solicite a soporte la actualización de la rutina vía ticket;

  • PONCLAPO18/06/2019
  • PONXFUN 08/10/2019
  • PONXAPO18/06/2019
  • PONA160 - 18/06/2019


3. Descargue el archivo de librerías acorde a la versión de su ambiente;

 
4. Aplicar las actualizaciones en su ambiente de pruebas inicialmente, con previo respaldo del RPO y eligiendo la opción "Aplicar solo fuentes actualizados";


5. Al final del artículo se anexa la configuración de la consulta estándar <F3> (SXB) SR6 asignada a los campos PF_TURNODE y PF_TURNOPA, garantice que su configuración este homologada a la enviada por soporte;


6. Garantice tener registrada la tabla de Horario Estándar (PONA080);



7. Garantice tener informados los siguientes parámetrosMV_CALDEM = 0, MV_CALFIS = 1 MV_USESPJ = 0 y MV_MODFOL = 2 (México, Argentina, Colombia, Chile, República Dominicana) o MV_MODFOL = 1  (Para País Bolivia, Perú) o MV_MODFOL = 0 (País Paraguay, Uruguay);



8. Una vez garantizado los puntos anteriores, valide nuevamente la ejecución de la rutina Cambio de Turno(PONA160), al final del artículo se anexa el video de validación de soporte.
 

Importante

No debe ser descargado, ni aplicado ningún patch de actualización de
acumulado semanal o anual de Recursos Humanos disponible en el portal del cliente; 
Ya que estas actualizaciones corresponde a funcionalidades para el país de Brasil
y pueden impactar de manera negativa o bien generar sus resultados erróneos
en las rutinas del módulo de Reloj Registrador Electrónico y/o Gestión de personal,
para países de Mercado Internacional



Conozca más:
Para consultar la información contenida en nuestro banco de conocimientos, acceda al siguiente enlace:

Help On-Line - Cambio de turno (PONA160)

 


*************** Archivo de validación Soporte Mercado Internacional *************** 

¿Fue útil este artículo?
Usuarios a los que les pareció útil: 0 de 0

0 Comentarios

Inicie sesión para dejar un comentario.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Rellene los campos siguientes para iniciar el chat:

Chat _