FAQs - Suporte técnico

Cross Segmentos - TOTVS BackOffice (Línea Protheus) MI - Compras (SIGACOM) - SCGN000076: Error : 207 (S0022) (RC=-1) - [Microsoft][SQL Server Native Client 11.0][SQL Server]Invalid column name 'B1_PRDORI'.

Ocurrencia
En módulo de Compras, al intentar realizar el borrado de un producto en rutina MATA010-Productos se detona el error.log:

SCGN000076: Error : 207 (S0022) (RC=-1) - [Microsoft][SQL Server Native Client 11.0][SQL Server]Invalid column name 'B1_PRDORI'.
( From tMSSQLConnection::GetQueryFile )

mceclip1.png


Ambiente
Cross Segmentos - TOTVS BackOffice (Línea Protheus) MI - Compras (SIGACOM) – A partir de versión 12

Causa
Este incidente ocurre porque el campo de contradominio (B1_PRDORI) tiene una relación de tabla SX9, pero este no se encuentra en tabla SX3. El campo sólo es utilizado en país localizado Brasil, por lo que la relación no debe existir en ambientes de países para Mercado Internacional.

Solución
Para solucionar esta ocurrencia, realice los siguientes pasos:
1. En el error.log, localice la relación que origina el error.
mceclip3.png

2. Por medio de apsdu abrir el archivo SX9 y filtrar para la relación correspondiente.

3. Retire el registro que contiene la validación.

4. Ingresar nuevamente al sistema y validar el borrado del producto.

¿Fue útil este artículo?
Usuarios a los que les pareció útil: 0 de 0

0 Comentarios

Inicie sesión para dejar un comentario.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Rellene los campos siguientes para iniciar el chat:

Chat _