Ocurrencia
En el módulo Compras, durante el registro de un Retorno de Mejora mediante la rutina Remito de Entrada (MATA102N), al confirmar los datos de la pantalla Retorno de Beneficio, el sistema presenta el mensaje: "No se identificó ninguna remesa de beneficio para esta orden de producción." y no permite continuar el registro a pesar de que sí existe remisión.
Ambiente
Cross Segmentos - TOTVS BackOffice (Línea Protheus) - MI - Compras (SIGACOM) - Versión 12
Causa
Este incidente ocurre por inconsistencia en el diccionario de datos, específicamente porque los campos de Orden de Producción en las tablas SD4 y SD1 existen con tamaño diferente.
Solución
Para solucionar esta ocurrencia, ajuste el tamaño de los campos D1_OP y D4_OP para el mismo tamaño. El tamaño estándar de ambos campos es 14. Para ajustar los campos realice el siguiente procedimiento:
1. Ingrese a Configurador de Sistema (SIGACFG) con usuario Administrador y acceso exclusivo;
2. Acceda a la rutina Base de Datos (CFGX031) y seleccione la opción Diccionario de Datos;
3. Edite la tabla SD1 y verifique si el campo D1_OP tiene tamaño 14, en caso contrario, ajuste el tamaño;
4. Edite la tabla SD4 y verifique si el campo D4_OP tiene tamaño 14, en caso contrario, ajuste el tamaño;
5. Grabe las modificaciones y actualice el diccionario de datos.
Importante
El mensaje ya no será presentado en circuitos registrados después del ajuste de los campos. Para registros ya grabados, el ajuste no tiene funcionamiento. Para esos casos, se sugiere revertir el circuito de envío y grabar nuevamente la orden de producción.
0 Comentarios