Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - TOTVS BackOffice (Línea Protheus) - MI - Contabilidad de Gestión (SIGACTB) - Se presenta error de duplicidad al modificar un Asiento Contable (CTBA102)

Ocurrencia
En el módulo de Contabilidad de Gestión (SIGACTB), al modificar algún valor de un asiento contable, después de dar clic en botón de grabar se presenta el siguiente error de duplicidad:

"THREAD ERROR ([9964], Luis, HELP2018CFSJ2) 14/10/2019 14:59:32
CT2010: DB error (Update): -29 File: CT2010 - Error : 2601 (23000) (RC=-1) - [Microsoft][SQL Server Native Client 11.0][SQL Server]Cannot insert duplicate key row in object 'dbo.CT2010' with unique index 'CT2010_UNQ'. The duplicate key value is (010101, 20191014, 008850, 001, 000001, 002, 01, 010101, 01, , 0).
( From tISAMFile::Update )
Thread ID [2484] User [Administrador] IO [6129] Tables [40] MaxTables [40] Comment [CTBA102 - TCPIP - ThreadID(9964)] SP [ ] Traced [No] SQLReplay [No] InTran [Yes] DBEnv [MSSQL/DADOSPRB] DBThread [(SPID 60,62)] Started [14/10/2019 14:59:12] IP [10.149.4.33:1231] IDLE [ ] InTransact [0 s.] Memory [780528] Running [ROP_UPDATE] RCV [176600] SND [967055] TCBuild [20181212-20190211] TCVersion [18.2.1.0] ARCH [64] OS [WINDOWS] BUILD [RELEASE]
UPDATE dbo.CT2010 SET CT2_LINHA = ?,CT2_DC = ?,CT2_DEBITO = ?,CT2_VALOR = ?,CT2_HIST = ?,CT2_TPSALD = ?,CT2_MANUAL = ?,CT2_SEQHIS = ?,CT2_SEQLAN = ?,CT2_CRCONV = ?,CT2_CTLSLD = ?,CT2_USERGA = ?,CT2_CODCLI = ?,D_E_L_E_T_ = ?,R_E_C_D_E_L_ = ? WHERE R_E_C_N_O_ = ?
-- Binded Parameters List --
#1 [C] [002]
#2 [C] [1]
#3 [C] [11310200 ]
#4 [N] [540000.000000]
#5 [C] [NDC-000100002563/ CLI002/PRUEBAS R.I. 2 ]
#6 [C] [1]
#7 [C] [1]
#8 [C] [001]
#9 [C] [002]
#10 [C] [1]
#11 [C] [0]
#12 [C] [ 0# 0@ 00ˆ 00‰ ]
#13 [C] [CLI002]
#14 [C] [ ]
#15 [N] [0.000000]
#16 [N] [2596.000000]
on CTBGRVCT2(CTBXATU.PRW) 14/01/2019 17:02:33 line : 1492"


Ambiente
Cross Segmentos - TOTVS BackOffice (Línea Protheus) - MI - Contabilidad de Gestión (SIGACTB) - A partir de versión 12

Causa
El error de duplicidad se presenta por desactualización de las rutinas CTBA102 y CTBXATU.

Solución
Para solucionar esta ocurrencia es necesario actualizar las siguientes rutinas: 

  • CTBA102 a una versión igual o superior al 02/10/2019.
  • CTBXATU a una versión igual o superior a 03/10/2019.

Para llevar a cabo la actualización de las rutinas mencionadas, realice los siguientes pasos:

  1. Solicitar los paquetes de actualización al área de soporte para Mercado Internacional;
  2. Haga un respaldo de su Repositorio de Objetos (RPO);
  3. Aplique los paquetes de corrección (patch).
¿Fue útil este artículo?
Usuarios a los que les pareció útil: 0 de 0

0 Comentarios

Inicie sesión para dejar un comentario.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Rellene los campos siguientes para iniciar el chat:

Chat _