Ocurrencia
En el módulo de Contabilidad de Gestión (SIGACTB), al modificar algún valor de un asiento contable, después de dar clic en botón de grabar se presenta el siguiente error de duplicidad:
"THREAD ERROR ([9964], Luis, HELP2018CFSJ2) 14/10/2019 14:59:32
CT2010: DB error (Update): -29 File: CT2010 - Error : 2601 (23000) (RC=-1) - [Microsoft][SQL Server Native Client 11.0][SQL Server]Cannot insert duplicate key row in object 'dbo.CT2010' with unique index 'CT2010_UNQ'. The duplicate key value is (010101, 20191014, 008850, 001, 000001, 002, 01, 010101, 01, , 0).
( From tISAMFile::Update )
Thread ID [2484] User [Administrador] IO [6129] Tables [40] MaxTables [40] Comment [CTBA102 - TCPIP - ThreadID(9964)] SP [ ] Traced [No] SQLReplay [No] InTran [Yes] DBEnv [MSSQL/DADOSPRB] DBThread [(SPID 60,62)] Started [14/10/2019 14:59:12] IP [10.149.4.33:1231] IDLE [ ] InTransact [0 s.] Memory [780528] Running [ROP_UPDATE] RCV [176600] SND [967055] TCBuild [20181212-20190211] TCVersion [18.2.1.0] ARCH [64] OS [WINDOWS] BUILD [RELEASE]
UPDATE dbo.CT2010 SET CT2_LINHA = ?,CT2_DC = ?,CT2_DEBITO = ?,CT2_VALOR = ?,CT2_HIST = ?,CT2_TPSALD = ?,CT2_MANUAL = ?,CT2_SEQHIS = ?,CT2_SEQLAN = ?,CT2_CRCONV = ?,CT2_CTLSLD = ?,CT2_USERGA = ?,CT2_CODCLI = ?,D_E_L_E_T_ = ?,R_E_C_D_E_L_ = ? WHERE R_E_C_N_O_ = ?
-- Binded Parameters List --
#1 [C] [002]
#2 [C] [1]
#3 [C] [11310200 ]
#4 [N] [540000.000000]
#5 [C] [NDC-000100002563/ CLI002/PRUEBAS R.I. 2 ]
#6 [C] [1]
#7 [C] [1]
#8 [C] [001]
#9 [C] [002]
#10 [C] [1]
#11 [C] [0]
#12 [C] [ 0# 0@ 00ˆ 00‰ ]
#13 [C] [CLI002]
#14 [C] [ ]
#15 [N] [0.000000]
#16 [N] [2596.000000]
on CTBGRVCT2(CTBXATU.PRW) 14/01/2019 17:02:33 line : 1492"
Ambiente
Cross Segmentos - TOTVS BackOffice (Línea Protheus) - MI - Contabilidad de Gestión (SIGACTB) - A partir de versión 12
Causa
El error de duplicidad se presenta por desactualización de las rutinas CTBA102 y CTBXATU.
Solución
Para solucionar esta ocurrencia es necesario actualizar las siguientes rutinas:
- CTBA102 a una versión igual o superior al 02/10/2019.
- CTBXATU a una versión igual o superior a 03/10/2019.
Para llevar a cabo la actualización de las rutinas mencionadas, realice los siguientes pasos:
- Solicitar los paquetes de actualización al área de soporte para Mercado Internacional;
- Haga un respaldo de su Repositorio de Objetos (RPO);
- Aplique los paquetes de corrección (patch).
0 Comentarios