Ocurrencia
En el módulo Financiero, al intentar anular la liquidación de un cheque, la rutina FINA089 se queda ciclada y tarda en finalizar el proceso.
Ambiente
Cross Segmentos - TOTVS Backoffice (Línea Protheus) MI - Financiero (SIGAFIN) – A partir de la versión 12.1.17
Causa
Este incidente ocurre debido a que el campo FKA_IDPROC es almacenado vacío al momento de liquidar el cheque del cobro diverso. El campo FKA_IDPROC de la tabla FKA almacena el identificador de proceso que le permite al sistema diferenciar los registros de las tablas FKA, FK1 y FK5 vinculados a un mismo cobro diverso, sin embargo en en estos casos dentro de la tabla FKA gran parte de los registros se encuentran con el campo FKA_IDPROC vacío. Al no existir el identificador de proceso para los registros del cheque cuya liquidación se esta anulando, el sistema toma todos los registros con el campo FKA_IDPROC vacío como parte de un mismo movimiento, lo que origina que sean leídos todos estos registros de la tabla FKA y a su ves todos los registros vinculados en las tablas FK1 y FK5 impactando en el desempeño de la rutina, quedando dentro en un ciclo de lectura.
Solución
Para solucionar esta ocurrencia, realice los siguientes pasos:
1. Actualice la rutina FINA089 con fecha mayor o igual al 17/07/2019, en caso de no contar con dicha actualización solicite el patch al equipo de Soporte a través de un ticket. Con esta actualización el incidente quedará corregido para nuevos cheques;
2. Reestructurar la información histórica de las tablas FKA, FK1, FK5, FK7 a través de la rutina FINXSE5 con el objetivo de evitar que para los registros ya existentes en su tabla FKA cuyo campo FKA_IDPROC se encuentra vacío, pueda continuar presentándose este incidente. Para conocer utilizar la rutina FINXSE5 vea el articulo: MP - FIN - Como puedo reestructurar las tablas FK´s (FKA, FK1, FK5, FK7)
0 Comentarios