Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - TOTVS Backoffice (Línea Protheus) MI - Financiero (SIGAFIN) - Al anular un cobro diverso con forma de pago cheque, la rutina se queda ciclada y tarda en finalizar

Ocurrencia
En el módulo Financiero, al intentar anular un cobro diverso con forma de pago cheque, la rutina FINA088 se queda ciclada y tarda en finalizar el proceso.

Ambiente
Cross Segmentos - TOTVS Backoffice (Línea Protheus) MI - Financiero (SIGAFIN) – A partir de la versión 12.1.17

Causa
Este incidente ocurre debido a que el campo FKA_IDPROC es almacenado vacío al momento de liquidar el cheque del cobro diverso. El campo FKA_IDPROC de la tabla FKA almacena el identificador de proceso que le permite al sistema diferenciar los registros de las tablas FKA, FK1 y FK5 vinculados a un mismo cobro diverso, sin embargo en en estos casos dentro de la tabla FKA gran parte de los registros se encuentran con el campo FKA_IDPROC vacío. Al no existir el identificador de proceso para los registros del cobro diverso que se esta anulando, el sistema toma todos los registros con el campo FKA_IDPROC vacío como parte de un mismo cobro diverso, lo que origina que sean leídos todos estos registros de la tabla FKA y a su ves todos los registros vinculados en las tablas FK1 y FK5 impactando en el desempeño de la rutina, quedando dentro en un ciclo de lectura.

Solución
Para solucionar esta ocurrencia, realice los siguientes pasos:

1. Actualice la rutina FINA089 con fecha mayor o igual al 17/07/2019, en caso de no contar con dicha actualización solicite el patch al equipo de Soporte a través de un ticket. Con esta actualización el incidente quedará corregido para nuevos cobros diversos;
2. Reestructurar la información histórica de las tablas FKA, FK1, FK5, FK7 a través de la rutina FINXSE5 con el objetivo de evitar que para los registros ya existentes en su tabla FKA cuyo campo FKA_IDPROC se encuentra vacío, pueda continuar presentándose este incidente. Para conocer utilizar la rutina FINXSE5 vea el articulo: MP - FIN - Como puedo reestructurar las tablas FK´s (FKA, FK1, FK5, FK7)

¿Fue útil este artículo?
Usuarios a los que les pareció útil: 0 de 0

0 Comentarios

Inicie sesión para dejar un comentario.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Rellene los campos siguientes para iniciar el chat:

Chat _