Ocurrencia
En el modulo de Compras (SIGACOM), al ingresar a la rutina Tipos de entradas y salidas (MATA080) se genera un error.log:
DB error (Insert): -37 File: SFC010 - Error : 2601 (23000) (RC=-1) - [Microsoft][ODBC Driver 17 for SQL Server][SQL Server]Cannot insert duplicate key row in object 'dbo.SFC010' with unique index 'SFC010_UNQ'. The duplicate key value is ( , 001, 01, IVC, 0).
Ambiente
Cross Segmentos - TOTVS BackOffice (Línea Protheus) - MI - Compras (SIGACOM) - Versión 12117
Causa
Este incidente ocurre por desactualización de la rutina MATA080 o bien por desactualización de rutinas de librerías.
Solución
Para solucionar esta ocurrencia, realice los siguientes pasos:
1. Descargue y aplique el archivo de librerías 19-04-11-LIB_LABE
2. Garantice tener la rutina MATA080 con fecha igual o superior a 25/04/2019 y la rutina LOCXFUN con fecha igual o superior a 14/05/2019, solicitar a soporte Mercado Internacional el patch de actualización vía ticket;
3.- Aplicar las actualizaciones en su ambiente de PRUEBAS inicialmente con previo respaldo del RPO;
4.- Desde APSDU abra, respalde las tablas SF4, SFC, SFB;
- Garantice no tener registros activos y vacíos
- Garantice no tener registros duplicados, de ser así, delete los registros duplicados
- Aplique un PACK para borrar físicamente los registros deletados (inactivos y en gris)
5. Una vez garantizados los puntos anteriores, ingrese nuevamente a la rutina Tes de entrada y salida (MATA080), valide el escenario reportado.

Nota: En caso de requerir apoyo para la revisión del un escenario especifico en su ambiente, deberá registrar un ticket de atención a Soporte Mercado Internacional, donde deberá anexar su vídeo de evidencia con el patrón de emulación y configuraciones a considerar.
Vídeo: ¿Como abrir un ticket de atención en el Portal del Cliente?
Conozca más:
Para consultar la información contenida en nuestro banco de conocimientos, acceda a los siguientes enlaces:
Help On-Line Tipos de Entradas y Salidas - TES (MATA080)
How To - Como responder la encuesta de satisfacción de tickets de atención TOTVS.
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