Ocurrencia
En el modulo de Contabilidad de Gestión (SIGACTB) al configurar las preguntas de la rutina Reversión de calculo de resultados (CTBA215), en la pregunta ¿Tipo de saldo? la consulta (F3) se muestra sin registros, situación que puede generar errores en el procesamiento de saldos contables como por ejemplo:
MP - CTB - CTBA215 - Error : 2601 (23000) No se puede insertar una fila de clave duplicada en el objeto 'dbo.CQ8010' con índice único 'CQ8010_UNQ'
Ambiente
Cross Segmentos - TOTVS BackOffice (Línea Protheus) - MI - Contabilidad de Gestión (SIGACTB) - Versión 12
Causa
Este incidente puede ocurrir por que en la tabla de TOPConnect SX5 no se encuentra la tabla alfanumérica SL que corresponde a los tipo de saldos contables, por registros históricos duplicados en la tabla CQ8 producto de una migración o importación de datos; Inconsistencia en el tamaño de los entes contables en las tablas de la familia CQ's; O bien por desactualización de las rutinas contables involucradas en el escenario reportado.
Solución
Para solucionar esta ocurrencia, realice los siguientes pasos:
1.- Garantice tener registrada la tabla alfanumérica SL de tipo de saldos contables en la rutina Tablas desde el modulo configurador;
- Se muestran las tabla alfanuméricas contenidas en la SX5 de un ambiente estándar de soporte;
- Al final del articulo se anexa la tabla SX5 de un ambiente estándar de soporte con sigamat a dos dígitos, para su consideración;
2.- Garantice tener la siguiente información en la tabla SL;
- Se consulta la información desde APSDU;
3.- Garantizados los puntos anteriores, ingrese a la consulta (F3) de la pregunta ¿Tipo de saldo? en la rutina Reversión de calculo de resultados (CTBA215);
4.- Ejecute la rutina CTBA215, valide que no sea generado ningún error.log.
Nota: En caso de requerir apoyo para la revisión del un escenario especifico en su ambiente, deberá registrar un ticket de atención a Soporte Mercado Internacional, donde deberá anexar su vídeo de evidencia con el patrón de emulación y configuraciones a considerar.
Vídeo: ¿Como abrir un ticket de atención en el Portal del Cliente?
Conozca más:
Para consultar la información contenida en nuestro banco de conocimientos, acceda a los siguientes enlaces:
Help On-Line Reversión de cálculo de resultado (CTBA215)
How To - Como responder la encuesta de satisfacción de tickets de atención TOTVS.
**** Archivo SX5 de un ambiente estándar de soporte con sigamat a dos dígitos.****
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