Ocurrencia
En el modulo de Contabilidad de Gestión (SIGACTB), al ejecutar la rutina Reversión de calculo de resultados (CTBA215) se genera un error.log
Ambiente
Cross Segmentos - TOTVS BackOffice (Línea Protheus) MI - Contabilidad de Gestión (SIGACTB) - Versión 12117
Causa
Este incidente puede ocurrir por diversos factores como por ejemplo, registros históricos duplicados en la tabla CQ8 producto de una migración o importación de datos; Inconsistencia en el tamaño de los entes contables en las tablas de la familia CQ's; O bien por desactualización de las rutinas contables involucradas en el escenario reportado.
Solución
Para solucionar esta ocurrencia, realice los siguientes pasos:
1.- Al final del articulo de anexa patch de actualización de las rutina contables involucradas en el escenario reportado;
- Aplicar en su ambiente de pruebas con previo respaldo del RPO y eligiendo la opción "Aplicar solo fuentes actualizados".
2.- Garantice tener el mismo modo de compartición de las tablas de la familia CQ's, se anexa articulo donde se indica este punto;
- Articulo: MP - CTB - Help: TabelaCQ es necesario ejecutar el reprocesamiento de saldos en rutina CTBA102
3.- Garantice que el tamaño de los entes contables de Centro de costos (CTT), Ítem contable (CTD) y Clase valor (CTH) estén homologados en tamaño en el catalogo de cada ente así como en las tablas de la familia CQ's;
4.- En caso de persistir el error.log de duplicidad de registros en la tabla CQ8 al ejecutar la rutina Reversión calculo de resultados (CTBA215), deberá realizar el siguiente paliativo;
- a) Desde APSDU, abra las tabla CQ8 y CQ9, realice un respaldo de cada tabla;
- b) Obtenga la fecha del primer registro de la tabla CQ8 (Orden cronológico);
- c)Con el respaldo realizado, aplique un ZAP en cada tabla para borrar los registros existentes;
- d) Ejecute la rutina de reprocesamiento de saldos (CTBA190) a partir de la fecha obtenida en el punto b);
- verifique que se hayan generado los registros en las tabla CQ8 y CQ9;
5.- Una vez aplicado el patch y garantizado los puntos anteriores, ejecute nuevamente la rutina CTBA215.
NOTA: En caso de identificar algún incidente, escenario, error o duda en especifico, deberá registrar un ticket de atención a soporte Mercado Internacional para su evaluación correspondiente.
--- Proporcionar en el ticket su evidencia en vídeo o en el formato MIT000 el patrón de emulación, las configuraciones utilizadas en el escenario
--- Enviar SX6
--- Log completo del error en bloc de notas (En caso de que aplique)
Vídeo: ¿Como abrir un ticket de atención en el Portal del Cliente?
Conozca más:
Para consultar la información contenida en nuestro banco de conocimientos, acceda al siguiente enlace:
Help On-Line Reversión de cálculo de resultado (CTBA215)
How To - Como responder la encuesta de satisfacción de tickets de atención TOTVS.
*** Archivo de validación y Patch de actualización.***
0 Comentarios