Ocurrencia
En el módulo de Reclutamiento y Selección de Personal (SIGARSP), al ingresar un candidato como empleado a través de la rutina Ingreso (RSMP001), no se están grabando algunos campos configurados en el archivo RSDEPA.TXT de la tabla SQG (Currículos) a la tabla SRA (Empleados).
Ambiente
TOTVS RH - TOTVS RH (Línea Protheus) - MI - Reclutamiento y Selección de Personal (SIGARSP) – Release - 11.80
Causa
Este incidente puede ocurrir por inconsistencias en la configuración de la estructura de archivo RSPDEPA.TXT
Solución
Para solucionar esta ocurrencia, realice los siguientes pasos:
1. En la revisión de la rutina RSPM001 se ha identificado que el formato del archivo RSPDEPA.TXT debe estar utilizando 60 posiciones, donde:
- Las primeras 30 posiciones se destinan a completar los campos de la Tabla de candidatos (SQG).
- Las otras 30 posiciones se destinan a completar los campos del Archivo de empleados (SRA).
2. Existe error en la configuración del archivo “RSPDEPA.TXT” para ejemplificar el incidente, los campos RA_PRINOME, RA_SECNOME, RA_PRISOBR, RA_SECSOBR tienen una separación con tabulador, lo cual es incorrecto, se debe utilizar la barra espaciadora para indicar los espacios y colocar los campos en la posición que le corresponden;
3. En la siguiente imagen, el campo SQG->QG_PRINOME se observa finaliza en la columna 16 y el campo M->RA_PRINOME inicia en la columna 24; Al tener posiciones divididos con Tabulador, no cumple con los espacios requeridos para la lectura en el ingreso de los empleados;
4. En la siguiente imagen, el campo SQG->QG_NOME se observa finaliza en la columna 13 y el campo M->RA_NOME inicia en la columna 31; Si cumple con los espacios requeridos (Sin tabulación) para la lectura en el ingreso de los empleados;
5. Es necesario realice los ajustes que correspondan (con la barra de espacio) para los espacios requeridos en los campos que no son grabado en la tabla SRA proveniente de la tabla SQG, una vez corregido su archivo “RSPDEPA.TXT”, valide nuevamente el ingreso del candidato como empleado a través de la rutina RSPM001.
Nota: En caso de identificar algún incidente, escenario, error o duda en específico, deberá registrar un ticket de atención a soporte Mercado Internacional para su evaluación correspondiente.
--- Proporcionar en el ticket su evidencia en vídeo el patrón de emulación, las configuraciones utilizadas en el escenario.
--- Enviar SX6 de la empresa / filial donde se presenta el incidente.
--- Log completo del error en bloc de notas, en caso de aplicar.
Vídeo: ¿Como abrir un ticket de atención en el Portal del Cliente?
Conozca más:
Para consultar la información contenida en nuestro banco de cocimientos, acceda a los siguientes enlaces:
Help On-Line - Ingreso (RSPM001)
How To - Como responder la encuesta de satisfacción de tickets de atención TOTVS
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