Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - TOTVS BackOffice (Línea Protheus) MI - Configurador (SIGACFG) - Argument #0, parameter oModel error, expected O->U on FWMVCROTAUTO(FWROTINAAUTOMATICAMVC.PRX)

Ocurrencia
Se presenta error log al intentar importar registros a la tabla de proveedores (SA2) con el uso de MILE.

El error log es el siguiente: "argument #0, parameter oModel error, expected O->U on FWMVCROTAUTO(FWROTINAAUTOMATICAMVC.PRX)"


Ambiente
Cross Segmentos - TOTVS BackOffice (Línea Protheus) MI - Configurador (SIGACFG) - A partir de la versión 11.80

Causa
Este incidente es ocasionado por la configuración del "Tipo Adapter" dentro del Layout del MILE.

Solución
En este caso para la rutina de proveedores (MATA020) se debe configurar el layout con el tipo Adapter "2 - MVC". 

Daptar_MVC.png

 

El motivo por el que se debe configurar con este tipo adapter, es porque la rutina está desarrollada en MVC.

 

Conozca más:

MP - CFG - Que es el MILE

MP - CFG - Como crear un layout de MILE

¿Fue útil este artículo?
Usuarios a los que les pareció útil: 0 de 0

0 Comentarios

Inicie sesión para dejar un comentario.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Rellene los campos siguientes para iniciar el chat:

Chat _