Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

FRAMEWORK - Framework (Línea Protheus) MI - E008_CATALINA_HOME al ejecutar el informe birt

Ocurrencia
En el módulo de Facturación, al ejecutar la impresión de informes, tanto en informes estándar como en los personalizados, ocurre el error log “E008_CATALINA_HOME:Variable de entorno CATALINA_HOME no se definio en el servidor del Protheus Server. on GETVIEWERDIR(BIRTREPORT.PRW)”


Ambiente
FRAMEWORK - Framework (Línea Protheus) MI – A partir de versión 11.8

Causa 
Ese error ocurre porque no fue configurada la variable de entorno del sistema CATALINA_HOME

Solución
Para solucionar esa ocurrrencia, realice los siguientes pasos:
1. Configure la variable del ambiente CATALINA_HOME conforme la siguiente documentación:
BIRT | Instalação e Configuração

2. En caso de continuar con el error una vez creada la variable, verifique que la variable creada sea de sistema y no de usuario, ya que la variable de usuario funcionara localmente después de reiniciar el Appserver. Las configuraciones de la sección Reportservice también pueden influenciar:
1.png

Si el valor de la variable esta incorrecto en la variable catalina_home, ocurre el error “argument #1 error, expected C->U, function fwrite on CREATECONFIGFILE(BIRTREPORT.PRW)”
2.png

¿Fue útil este artículo?
Usuarios a los que les pareció útil: 0 de 0

0 Comentarios

Inicie sesión para dejar un comentario.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Rellene los campos siguientes para iniciar el chat:

Chat _