Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - TOTVS BackOffice (Línea Protheus) MI - Contabilidad de Gestión (SIGACTB) - clave duplicada en el objeto 'dbo.CQ2020' con índice único 'CQ2020_UNQ'.

Ocurrencia
En el modulo de Contabilidad de Gestión, al ejecutar la rutina CTBA211-Cálculo de Resultados, es generado el error: 

DB error (Insert): -37 File: CQ2020 - Error : 2601 (23000) (RC=-1) - [Microsoft][SQL Server Native Client 11.0][SQL Server]No se puede insertar una fila de clave duplicada en el objeto 'dbo.CQ2020' con índice único 'CQ2020_UNQ'.

Ambiente
Cross Segmentos - TOTVS BackOffice (Línea Protheus) MI - Contabilidad de Gestión (SIGACTB) – Versión 12

Causa
Estos tipos de errores de llaves duplicadas en las tablas de saldos contables para la versión de 12 de Protheus en las tablas de saldos contables (Familia CQ's) regularmente ocurren por inconsistencias de diccionario de datos, específicamente para la longitud de preguntas y campos de los entes contables: Cuenta contable, Centro de costos, Clase valor o bien Ítem Contable.

Solución
Para solucionar esta ocurrencia, realice los siguientes pasos:
1. Inicialmente realizar el respaldo de su base de datos y diccionario de datos.
2. Con acceso exclusivo al sistema (ningún usuario conectado a Protheus) verificar el tamaño de los campos de los entes contables: "Código de Cuenta" CT1_CONTA, "Centro de Costo" CTT_CUSTO, "Item Contable" CTD_ITEM y "Clase Valor" CTH_CLVL. Estos deben tener el mismo tamaño de acuerdo al procedimiento de alteración en el tamaño de entes contables:
Procedimiento para alteración de tamaño de entidades contable

Verificar, que tanto las preguntas como campos que se consideran en cada uno de los Grupos: Conta Contabil, Centro de Custo, ítem Contabil, Classe de Valor tengan el mismo tamaño.

Ejemplo:
Grupo de Campos Centro Custo: Todos los campos y las preguntas que pertenecen al grupo de campos, deberán tener el mismo tamaño.


Para el caso puntual del error, referente a la rutina CTBA211, se deberá verificar la longitud del grupo de preguntas CTB211.

3. Una vez garantizado la homologación del tamaño de campos de los entes contables, así como la compartición de tablas del modulo de contabilidad, realice el reprocesamiento de Saldos, a través de la rutina CTBA190.

4. Valide nuevamente el escenario reportado y confirme que el error.log no se presenta.

Conozca más:
Para consultar la información contenida en nuestro banco de conocimientos, acceda a los siguientes enlaces:
MP - CTB - Tablas de Saldos contables CT's sustituidas por tablas de la familia CQ's
Help Online - Reprocesamiento de Saldos contables (CTBA190)

 

¿Fue útil este artículo?
Usuarios a los que les pareció útil: 0 de 0

0 Comentarios

Inicie sesión para dejar un comentario.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Rellene los campos siguientes para iniciar el chat:

Chat _