Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - TOTVS BackOffice (Línea Protheus) - MI - Compras (SIGACOM) - MATA010 - array out of bounds ( 19 of 18 ) on SWAPELEMENT(FWBRWMODELCONFIG.PRW) 23/10/2018 18:06:50 line : 688

Ocurrencia
En modulo de Compras (SIGACOM), al modificar las columnas del Browse de la rutina de productos (MATA010), se genera un error.log:

array out of bounds ( 19 of 18 )  on SWAPELEMENT(FWBRWMODELCONFIG.PRW) 23/10/2018 18:06:50 line : 688

Ambiente
Cross Segmentos - TOTVS BackOffice (Línea Protheus) - MI - Compras (SIGACOM) - Versión 12117


Causa
Este incidente puede ocurrir por desactualización de rutinas de librerías o bien porque los registros del profiler del usuario se corrompieron.


Solución
Para solucionar esta ocurrencia, realice los siguientes pasos:

1. Se sugiere tener la actualización de binarios y librerías disponibles en el portal del cliente, aplicados en su ambiente de pruebas inicialmente;

Downloads y atualizaciones de Librerias

Downloads y atualizaciones Binarios - APPSERVER

Downloads y atualizaciones Binarios - SMARTCLIENT

 

 

2. Realice un respaldo de la carpeta Profile contenida en su Protheus_Data de su ambiente, cuando tenga los servicios de Protheus Detenidos;


3. Levante los servicios de Protheus, ingrese a Configurador (SIGACFG)> Menú Ambiente / Archivos / Mantenimiento Profile (Programa - PROFMGR);

Articulo: MP - CFG - PROFMGR - Perfil del usuario Mantenimiento (Profile)


4. Borre los registros del usuario que está con el error.log;

c2.jpg

5. Ingrese a la rutina MATA010, valide el escenario reportado.



 

 

 

Conozca más:
Para consultar la información contenida en TDN, acceda a los siguientes enlaces:

TDN: Mantenimiento de Profile de Usuario

 

¿Fue útil este artículo?
Usuarios a los que les pareció útil: 0 de 0

0 Comentarios

Inicie sesión para dejar un comentario.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Rellene los campos siguientes para iniciar el chat:

Chat _