Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

TOTVS MANUFACTURA - TOTVS Manufactura (Línea Protheus) - MI - Mantenimiento de Activos (SIGAMNT) - MNTA420: Error al intentar agregar insumos en O. S. Correctiva: array out of bounds ( 0 of 20 ) on NG420LINOK (MNTA420.PRX)

Ocurrencia
En modulo de Mantenimiento de activos, al incluir insumos en la Orden de Servicio Correctiva en la rutina MNTA420, se genera el error.log "array out of bounds ( 0 of 20 ) on NG420LINOK (MNTA420.PRX)"


Ambiente
TOTVS MANUFACTURA - TOTVS Manufactura (Línea Protheus) - MI - Mantenimiento de Activos (SIGAMNT) – A partir de versión 12.1.17

Causa
Este incidente ocurre por que los campos TL_LOJA y TL_FORNEC no tienen el Check de "Usado" habilitado. Por estándar para el diccionario de datos padrón de versión 12.1.17, para países de Mercado Internacional, esta propiedad está habilitada.

Solución
Para solucionar este incidente, favor de efectuar los siguientes pasos:
1. Realizar un respaldo del diccionario de datos del ambiente donde replica el error;
2. Ingresar al módulo Configurador, con acceso exclusivo al sistema (ningún usuario conectado) en la opción del menú Base de Datos>Diccionario>Base de Datos, abrir en modo de edición la tabla STL;
3. Localizar los campos TL_LOJA y TL_FORNEC y confirmar que se tenga habilitada la propiedad de usado, como se muestra en la siguiente imagen:

4. Realizar la actualización del diccionario de datos por medio del Botón "Actualizar Base de Datos"
5. Ingresar a la rutina MNTA420-O. S. Correctiva y validar el proceso.

 

¿Fue útil este artículo?
Usuarios a los que les pareció útil: 0 de 0

0 Comentarios

Inicie sesión para dejar un comentario.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Rellene los campos siguientes para iniciar el chat:

Chat _