Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - TOTVS BackOffice (Línea Protheus) - MI - Stock y Costos (SIGAEST) - array out of bounds ( 0 of 45 ) on A241LINOK(MATA241.PRX)

Ocurrencia
En el módulo de Estock/Costos, al intentar registrar un movimiento interno múltiple desde la rutina MATA241 es presentado el error log:
1.jpg

Ambiente
Cross Segmentos - TOTVS BackOffice (Línea Protheus) - MI - Stock y Costos (SIGAEST) - A partir de la versión 12

Causa
El error de "array out of bounds ( 0 of ... )" ocurre cuando algún campo de array no se encuentra en uso por el Sistema o tiene un nivel superior al usuario, es decir, el campo no está disponible para el usuario.


Solución
Para solucionar esa ocurrencia, realice los siguientes pasos:
1. Inicialmente verifique que la rutina MATA241 sea igual o superior al 01/08/2018;

2. Desde el modulo Configurador - SIGACFG, verifique que los siguientes campos estén en uso y configurados como nivel 1 (conforme al diccionario estándar):

  • D3_LOCAL
  • D3_LOCALIZ
  • D3_COD
  • D3_NUMSERI
  • D3_LOTECTL
  • D3_NUMLOTE
  • D3_OP
  • D3_QUANT

3. Guarde las modificaciones en modo exclusivo y realice una nueva validación para verificar que el error log fue corregido.

¿Fue útil este artículo?
Usuarios a los que les pareció útil: 0 de 0

0 Comentarios

Inicie sesión para dejar un comentario.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Rellene los campos siguientes para iniciar el chat:

Chat _